Windows no me abre algunos programas ni cierra los procesos

Foro referente al sistema operativo Windows 7
Responder
nancoli81
Usuario linuxero
Usuario linuxero
Mensajes: 6
Registrado: 12 Mar 2020, 19:35
Agradecido: 0
Agradecimiento recibido: 0

Windows no me abre algunos programas ni cierra los procesos

Mensaje por nancoli81 » 12 Mar 2020, 19:44

Hola. Desde hace unos días Windows no me abre algunos programas, como Thunderbird o uTorrent. Lo extraño es que en el administrador de tareas aparecen en la lista de procesos, aunque no en la de aplicaciones. Trato de cerrar los procesos, pero no se cierran. He probado cerrarlos con taskkill y tampoco se cierran aunque me lance el mensaje de que se han cerrado. Esto me está resultando ya molesto. Por el uTorrent me da igual, pero por Thunderbird me preocupa más porque no puedo abrir el correo y revisar correos que tengo en las bandejas. ¿A alguien más le ha pasado? ¿qué solución me podéis dar? Muchas gracias de antemano.

:help:

Edito: He olvidado mencionar que esos procesos aparecen con *32, por si sirve de algo esta información.

Avatar de Usuario
pako
Usuario normaliko
Usuario normaliko
Mensajes: 481
Registrado: 08 Jun 2018, 19:40
Agradecido: 13 veces
Agradecimiento recibido: 36 veces

Re: Windows no me abre algunos programas ni cierra los procesos

Mensaje por pako » 13 Mar 2020, 16:12

Hola,

Los procesos que pone *32 suele referirse a que son programas de 32 bits, supongo que tu Windows será de 64 bits, entonces los programas que son de 64 bits no los pone como *64, pone su nombre sin más, pero los de 32 bits los suele poner como *32.

Es raro tu caso, porque aunque no te deje abrir la aplicación el proceso sí que te debería de dejar cerrarlo.

Yo terminaría las descargas que tengas en utorrent, lo desinstalaría, reiniciaría el equipo y después instalaría de nuevo el utorrent, para comprobar si ya te va bien o sigues con el mismo problema. Te digo con utorrent porque es más fácil que no hacerlo con Thunderbird y tener que configurar de nuevo los correos.

De todas maneras, además de thunderbird y utorrent, comentas que te pasa con más programas.
Has probado a pasar el escaneo completo del antivirus que uses habitualmente, después el malwarebytes anti-malware y por último el adwcleaner, para asegurarte que no sea una infección? (todo en sus versiones gratuitas).

Saludos
Si has encontrado aquí la ayuda que esperabas (o incluso si no ha sido así ;) ), ayúdanos a mantener el foro con un pequeño donativo.
¡Muchas gracias!

nancoli81
Usuario linuxero
Usuario linuxero
Mensajes: 6
Registrado: 12 Mar 2020, 19:35
Agradecido: 0
Agradecimiento recibido: 0

Re: Windows no me abre algunos programas ni cierra los procesos

Mensaje por nancoli81 » 13 Mar 2020, 17:11

Muchas gracias Pako por tu respuesta. Lo cierto es que sólo he notado el problema, de momento, en esos dos programas además de en Dropbox (tampoco es que me haya puesto a abrirlos todos), aunque con Dropbox realmente no iniciaba yo el programa, sino que este se iniciaba con Windows (hablo en pasado porque lo desactive en msconfig) y no podía cerrar el proceso. Al tratar de cerrar el proceso en alguna ocasión me lanza un error indicando que no se puede realizar la operación, aunque habitualmente no.aparece ningún error, únicamente no se cierra.

Respecto al antivirus, precisamente entre ayer y hoy le hice un escaneo completo con Avast, me queda pasarle Malwarebits, Superantispyware y algún programa más que tengo.

Seguiré haciendo pruebas en el momento que pueda y si lo resuelvo lo comentaré por aquí. No obstante, si alguien tiene alguna explicación/solución alternativa le agradecería que lo compartiese.

nancoli81
Usuario linuxero
Usuario linuxero
Mensajes: 6
Registrado: 12 Mar 2020, 19:35
Agradecido: 0
Agradecimiento recibido: 0

Re: Windows no me abre algunos programas ni cierra los procesos

Mensaje por nancoli81 » 14 Mar 2020, 10:38

Bueno, después de 9 horas de análisis completo de Avast, más unas cuantas horas de análisis en el arranque y de pasarle el Malwarebytes y Superantispyware, todo sigue igual. Debo añadir una observación que olvidé o más bien no le di importancia: en el caso de Thunderbird me dejó de funcionar justo después de empezar una actualización automática, la cual se quedó colgada y tuve que detener. En el caso de uTorrent creo que también se quiso actualizar de forma automática (ya que en Programas y características del Panel de control aparece como fecha de instalación el día que intenté ejecutarla por última vez). Además, cuando abrí Malwarebytes lo actualicé y la instalación también se quedó colgada, aunque al final sí que se instaló bien. En ese momento me llamó la atención un proceso llamado _iu14dn.tmp, el cual me pareció ver cuando traté de abrir uTorrent por última vez.

Decir que he intentado restaurar el sistema y ¿qué pasó? Algo muy parecido a lo de Thunderbird y uTorrent: no se abría el programa de restauración de Windows aunque sí que aparecía el proceso en el Administrador de tareas, con la diferencia de que en este caso sí que podía terminar el proceso.

Lo último que me ha pasado es que he tratado de desinstalar uTorrent y no puedo. En el Administrador de tareas me aparece el proceso uTorrent.exe, pero no se ejecuta el programa de desinstalación (llamado desde Programas y características) y tampoco puedo cerrar el proceso.

Esto me hace deducir que puede tratarse de algún problema relacionado con la actualización de software, con nuevas versiones o con software instalado después de alguna fecha concreta; pero ahora me mosquea que ni siquiera puedo restaurar el sistema.

Probaré si iniciando Windows en modo seguro puedo hacer algo.

Gracias

nancoli81
Usuario linuxero
Usuario linuxero
Mensajes: 6
Registrado: 12 Mar 2020, 19:35
Agradecido: 0
Agradecimiento recibido: 0

Re: Windows no me abre algunos programas ni cierra los procesos

Mensaje por nancoli81 » 14 Mar 2020, 11:16

Bien, he probado en Modo seguro y Modo seguro con funciones de red y esto es lo que ha pasado:

En Modo seguro se abren tanto uTorrent como Thunderbird, aunque sin conexión a Internet de poco sirven. En Modo seguro con funciones de red ocurre lo que me ocurre en modo normal.

Veo que Zone Alarm ya no se me inicia con Windows, y quizás sea algo que haya atacado al cortafuegos y no lo ejecute para que no proteja el equipo.

nancoli81
Usuario linuxero
Usuario linuxero
Mensajes: 6
Registrado: 12 Mar 2020, 19:35
Agradecido: 0
Agradecimiento recibido: 0

Re: Windows no me abre algunos programas ni cierra los procesos

Mensaje por nancoli81 » 14 Mar 2020, 11:46

En Modo seguro he ejecutado la herramienta para restaurar el sistema, pero al no tener puntos de recuperación no he podido hacer nada.

Espero que con toda la información me podáis echar un cable.

Muchas gracias.

nancoli81
Usuario linuxero
Usuario linuxero
Mensajes: 6
Registrado: 12 Mar 2020, 19:35
Agradecido: 0
Agradecimiento recibido: 0

Re: Windows no me abre algunos programas ni cierra los procesos

Mensaje por nancoli81 » 14 Mar 2020, 12:04

Bueno, parece ser que ya he resuelto el problema. Ya puedo abrir los programas que no podía abrir, y la solución ha sido tan fácil como activar el Firewall de Windows.

Seguiré investigando para ver el por qué de lo que sucedía, pero lo más importante es que ya puedo usar Thunderbird.

:D

Avatar de Usuario
pako
Usuario normaliko
Usuario normaliko
Mensajes: 481
Registrado: 08 Jun 2018, 19:40
Agradecido: 13 veces
Agradecimiento recibido: 36 veces

Re: Windows no me abre algunos programas ni cierra los procesos

Mensaje por pako » 16 Mar 2020, 12:20

Hola,

Por cierto, a que le llamas tú actualizaciones automáticas? normalmente los programas no se actualizan solos automáticamente, comprueban que hay nueva versión y te avisan, pero luego tienes que hacerlo tú de manera manual.

Según te iba leyendo y viendo que era al instalar o ejecutar programas de Windows iba pensando que podía estar relacionado con el .NET de Windows, que te actualizara el .NET Windows update y que por ahí vinieran los problemas.

Después la prueba del modo seguro y ver que sin funciones de red funciona bien y con funciones de red falla, ya apunta a algo relaciona con la red o internet. Y que ahora deje de funcionar ZoneAlarm, pues más apunta a eso.

Y ahora viendo que la solucion fue activar el Firewall de Windows, parece que el ZoneAlarm estaba corrupto o en conflicto con Windows, ya que parece que los programas que usaban internet, al pasar por el firewall petaban. Siendo raro justo eso, que no diga el programa sin acceso a internet o a la red o algo similar en vez de generar esos problemas. A no ser... que el Zone Alarm por lo que estoy viendo también hay versión antivirus, además de la del firewall y por ahí vayan los tiros.

Yo lo que haría, es pasar como administrador desde cmd el comando sfc/scannow. Así te comprobara si los archivos que usa Windows algún se corrompió y en tal caso te lo sustituirá por el original.
Ya sabiendo que Windows está bien, puedes volver a instalar el ZoneAlarm a ver si ahora te funciona bien, en caso que empiecen los problemas, ya sabes que desinstalar para que funcione. :jaja:

Saludos
Si has encontrado aquí la ayuda que esperabas (o incluso si no ha sido así ;) ), ayúdanos a mantener el foro con un pequeño donativo.
¡Muchas gracias!

Responder