No detecta salida de audio desde la placa base ni detecta dispositivos de audio

Foro referente al sistema operativo Windows 10
ang04
Usuario linuxero
Usuario linuxero
Mensajes: 4
Registrado: 20 Jul 2021, 02:18

No detecta salida de audio desde la placa base ni detecta dispositivos de audio

Mensaje por ang04 »

Hola :D, espero se encuentren bien, soy nuevo y espero que lo haga bien esta primera vez:

Bien, el caso es que hace tiempo adquirí un equipo (adjunto a continuación las especificaciones pertinentes del PC):

- Tarjeta Madre Asrock B550 Steel Legend
- Procesador AMD Ryzen 5 3600
- GPU: NVIDIA RTX 2060
- 16GB de RAM

Bueno, mi problema está en que al conectar auriculares (Con o sin micro) a alguna entrada de la placa base, no los detecta por lo que tampoco se cambia la salida de audio, ya intente en todas las entradas y con varios auriculares e incluso con bocinas :( ...

Ahora, tengo conectado el HDMI de la tarjeta grafica al monitor (También he usado display port, no sé si eso intervenga) y es el único dispositivo que si detecta para salida de audio por lo que si efectúa sonido, (tengo duda con los drivers, según tiene los de NVIDIA pero realmente no sé si sean el problema, la verdad soy muy novato y no sé si estoy checando bien o si lo que checo es lo correcto, ya que he visto que unos tienen los de Realtek pero no sé cuales necesito yo en este caso particular). El problema también llega a la entrada de audio, no detecta ningún dispositivo teniendo auriculares con micro conectados a la placa base, la verdad estoy muy confundido, ya no sé en donde moverle, realmente intente buscar una solución pero mis conocimientos técnicos llegaron al limite...

Adjunto evidencia, espero contar con su apoyo esperando que haya alguna solución, saludos colegas





Avatar de Usuario
pako
Usuario Bill Gates
Usuario Bill Gates
Mensajes: 1140
Registrado: 08 Jun 2018, 19:40

Re: No detecta salida de audio desde la placa base ni detecta dispositivos de audio

Mensaje por pako »

Hola,

Bienvenido!

Yo creo que no esta bien instalada la tarjeta de sonido.

Normalmente con la Realtek en la foto que pones de salidas suelen salir las tres aunque no estén activadas, por otro lado en entrada debería de salirte una y tampoco te sale.

Yo probaría a instalar los drivers de la placa madre de la pagina oficial y mas en tu caso que todos los drivers son de hace poquitos meses:

[Enlace externo eliminado para invitados]

Aunque solo te faltaría el driver de audio, lo ideal es que lo primero que instales el del chipset de la placa madre, que es en el que se basa todo:
AMD chipset driver ver:2.11.26.106

Después el driver de audio:
Realtek high definition audio driver ver:9030.1_UAD_WHQL_Nahimic
En esta descarga solo tienes el driver de audio, si te funciona bien con el no hace falta que instales mas.

Pero si te va mal, tienes que ir a la tienda Microsoft store y descargar el panel de control de Realtek como pone en esa pagina de asrock.
Porque tiene una mayor configuración y permite elegir para que son las entradas jack de 3,5 de la placa madre y mas cosas.

Saludos
Si has encontrado aquí la ayuda que esperabas (o incluso si no ha sido así ;) ), ayúdanos a mantener el foro con un pequeño donativo.
¡Muchas gracias!

ang04
Usuario linuxero
Usuario linuxero
Mensajes: 4
Registrado: 20 Jul 2021, 02:18

Re: No detecta salida de audio desde la placa base ni detecta dispositivos de audio

Mensaje por ang04 »

pako escribió: 20 Jul 2021, 22:47 Hola,

Bienvenido!

Yo creo que no esta bien instalada la tarjeta de sonido.

Normalmente con la Realtek en la foto que pones de salidas suelen salir las tres aunque no estén activadas, por otro lado en entrada debería de salirte una y tampoco te sale.

Yo probaría a instalar los drivers de la placa madre de la pagina oficial y mas en tu caso que todos los drivers son de hace poquitos meses:

[Enlace externo eliminado para invitados]

Aunque solo te faltaría el driver de audio, lo ideal es que lo primero que instales el del chipset de la placa madre, que es en el que se basa todo:
AMD chipset driver ver:2.11.26.106

Después el driver de audio:
Realtek high definition audio driver ver:9030.1_UAD_WHQL_Nahimic
En esta descarga solo tienes el driver de audio, si te funciona bien con el no hace falta que instales mas.

Pero si te va mal, tienes que ir a la tienda Microsoft store y descargar el panel de control de Realtek como pone en esa pagina de asrock.
Porque tiene una mayor configuración y permite elegir para que son las entradas jack de 3,5 de la placa madre y mas cosas.

Saludos
Hola, muchas gracias por tu ayuda sin embargo tengo varios problemas en este punto.

Primero que nada seguí tus pasos (gracias, no tome en cuenta buscar en la pagina oficial de la MoBo), aunque no sabía si instalar todos los drivers o solo los que me comentabas, así que solo instale el principal "AMD chipset driver ver:2.11.26.106" y procedí a instalar el de audio (Realtek high definition audio driver ver:9030.1_UAD_WHQL_Nahimic), aquí empieza la complicación ya que lo hice, al parecer todo iba bien, pero al reiniciar mi PC no hubo cambio alguno, seguían los mismos problemas. Ahora, trate de instalar el "Realtek Audio Console” pero para mi sorpresa no puedo instalarlo sale el error -Código: 0x803FB005- y parece ser que ya no "existe" si lo busco aparte en la Microsoft store (a pesar de que con el enlace que maneja Asrock si te envía a la app). Me encuentro en este punto, trate de solucionar el error que salía al instalar el "Realtek Audio Console” pero no hubo solución, también trate de buscar otra alternativa de drivers, instale el "Realtek HD Audio Drivers 2.82" pero no soluciono nada. No sé que alternativa buscar al "Realtek Audio Console” o que otro camino podríamos seguir para el problema desde los drivers. De antemano muchas gracias y espero exista alguna solución que podamos encontrar

Avatar de Usuario
pako
Usuario Bill Gates
Usuario Bill Gates
Mensajes: 1140
Registrado: 08 Jun 2018, 19:40

Re: No detecta salida de audio desde la placa base ni detecta dispositivos de audio

Mensaje por pako »

Hola,

Hoy en día no se suelen instalar los drivers desde la pagina web de la placa madre, porque Windows ya te los mete automáticamente y mas actualizados.
Pero algunas veces cuando Windows actualiza un driver de un componente puede que falle, entonces vienen bien los drivers de la pagina de la placa madre, porque son drivers testados por ellos y sabemos que funcionan al 100%.
En tu caso concreto, todos los drivers son de hace poquitos meses (de este año), así que no tendrás problemas en usarlos.

En cuanto a instalar todos, se suele instalar el del chipset primero, que es en el que se basa todo y después el driver del componente con el que tengamos problemas.
Todos los demás no es necesario meterlos porque Windows ya nos los instala directamente, pero puedes instalar todos como dices, no seria ningún problema, cambiaría los drivers que instalo Windows por los de Asrock, pero viendo que los de la pagina de Asrock son modernos probablemente serán hasta la misma versión del driver que te instalo Windows.

Volviendo a tu tema concreto...

Se suele instalar el driver de sonido desde la pagina de Asrock, si no es suficiente se instala el programa de gestión de Realtek que es el que te permite mayor configuración.
Te dije que lo instalaras desde la tienda de Microsoft, porque en la pagina de Asrock te dice que lo hagas así. Pero de toda la vida se hizo sin pasar por la tienda.
Se iba a la pagina oficial de Realtek, después desde la sección de descargas, se buscaba el que correspondía al chip de audio de la placa madre, se descargaba e instalaba y listo.

En tu caso concreto, tu placa madre tiene este:
7.1 CH HD Audio (Realtek ALC1220 Audio Codec), Nahimic Audio

Así que en la pagina de Realtek en dowload, deberías de buscar para el ALC1220, yo mire y no le encontré, aparecen otros ALC pero concretamente el 1220 yo no le vi, prueba a mirar a ver si tu le ves.

Yo en tu caso, intentaría instalar el "High Definition Audio Codecs Software" sin pasar por la tienda de Microsoft a ver si así te deja.

[Enlace externo eliminado para invitados]

Viendo el peso, supongo que el de 422MB en ejecutable, o el 427MB en zip, ademas del driver debería de venirte el programa de control.

No va a pasar nada por intentarlo, en el peor de los casos lo desinstalas. Y después desde el administrador de dispositivos, dentro de la rama "Entradas y salidas de audio", buscas el que ponga Realtek Hight Definition Audio, botón derecho sobre el y desinstalar.
Entonces pulsas arriba en el icono del monitor y la lupa, que es para buscar los cambios de hardware, volverá a encontrarlo y automáticamente te volverá a instalar los drivers de Windows y lo tendrás tal cual lo tenias.

O siempre puede crear un punto de restauración en Windows antes de modificar nada, así podrías después restaurarlo.

Saludos
Si has encontrado aquí la ayuda que esperabas (o incluso si no ha sido así ;) ), ayúdanos a mantener el foro con un pequeño donativo.
¡Muchas gracias!

ang04
Usuario linuxero
Usuario linuxero
Mensajes: 4
Registrado: 20 Jul 2021, 02:18

Re: No detecta salida de audio desde la placa base ni detecta dispositivos de audio

Mensaje por ang04 »

pako escribió: 21 Jul 2021, 11:33 Hola,

Hoy en día no se suelen instalar los drivers desde la pagina web de la placa madre, porque Windows ya te los mete automáticamente y mas actualizados.
Pero algunas veces cuando Windows actualiza un driver de un componente puede que falle, entonces vienen bien los drivers de la pagina de la placa madre, porque son drivers testados por ellos y sabemos que funcionan al 100%.
En tu caso concreto, todos los drivers son de hace poquitos meses (de este año), así que no tendrás problemas en usarlos.

En cuanto a instalar todos, se suele instalar el del chipset primero, que es en el que se basa todo y después el driver del componente con el que tengamos problemas.
Todos los demás no es necesario meterlos porque Windows ya nos los instala directamente, pero puedes instalar todos como dices, no seria ningún problema, cambiaría los drivers que instalo Windows por los de Asrock, pero viendo que los de la pagina de Asrock son modernos probablemente serán hasta la misma versión del driver que te instalo Windows.

Volviendo a tu tema concreto...

Se suele instalar el driver de sonido desde la pagina de Asrock, si no es suficiente se instala el programa de gestión de Realtek que es el que te permite mayor configuración.
Te dije que lo instalaras desde la tienda de Microsoft, porque en la pagina de Asrock te dice que lo hagas así. Pero de toda la vida se hizo sin pasar por la tienda.
Se iba a la pagina oficial de Realtek, después desde la sección de descargas, se buscaba el que correspondía al chip de audio de la placa madre, se descargaba e instalaba y listo.

En tu caso concreto, tu placa madre tiene este:
7.1 CH HD Audio (Realtek ALC1220 Audio Codec), Nahimic Audio

Así que en la pagina de Realtek en dowload, deberías de buscar para el ALC1220, yo mire y no le encontré, aparecen otros ALC pero concretamente el 1220 yo no le vi, prueba a mirar a ver si tu le ves.

Yo en tu caso, intentaría instalar el "High Definition Audio Codecs Software" sin pasar por la tienda de Microsoft a ver si así te deja.

[Enlace externo eliminado para invitados]

Viendo el peso, supongo que el de 422MB en ejecutable, o el 427MB en zip, ademas del driver debería de venirte el programa de control.

No va a pasar nada por intentarlo, en el peor de los casos lo desinstalas. Y después desde el administrador de dispositivos, dentro de la rama "Entradas y salidas de audio", buscas el que ponga Realtek Hight Definition Audio, botón derecho sobre el y desinstalar.
Entonces pulsas arriba en el icono del monitor y la lupa, que es para buscar los cambios de hardware, volverá a encontrarlo y automáticamente te volverá a instalar los drivers de Windows y lo tendrás tal cual lo tenias.

O siempre puede crear un punto de restauración en Windows antes de modificar nada, así podrías después restaurarlo.

Saludos
Buenas, nuevamente gracias por el apoyo, tarde bastante en descargar el "High Definition Audio Codecs Software" pero fue en vano, sigo teniendo el mismo problema, es más, solo me aparece los "programas instalados" donde si lo desinstale, pero en el "Administrador de dispositivos" ni rastro del driver, simplemente no está, es muy raro. Por otro lado, el driver para el Realtek ALC1220 es bastante difícil de encontrar ya que tampoco lo encontré, incluso busque en otras paginas que no eran Realtek.

Ahora, tengo una sospecha que no se si nos pueda ayudar en esto y no sé si va enfocado al problema (Adjuntare evidencia que resume lo que quiero describir a continuación)...

Primero, en mis "archivos del sistema (x86)" la carpeta de "Realtek" solo tiene 3 carpetas: "Audio", "dragon"(Que es la app para monitorear como maneja las redes mi PC a lo que entiendo) y "NICDRV_8169" (esta ni idea para que sirva)... La que nos interesa es la de Audio tengo entendido, ahora, dentro de la carpeta "Audio" hay dos carpetas: "Drivers" y "Installshield" (la cual solamente tiene un archivo: "Rtkupd64" que lo marca como aplicación ejecutable, me parece que tiene algo que ver con la API para el audio de Realtek, aún así al ejecutarlo no hace nada)... En la carpeta de "Drivers" solamente hay dos archivos "RtlUpd64" (Tiene las mismas características del único archivo de la carpeta anterior y al ejecutarlo pasa lo mismo: nada...), y otro archivo de tipo "Archivo ISS" llamado "USetup.iss", el cual no puedo abrir y no sé para que sirva... Adjunto imágenes





Para continuar, en la carpeta donde tengo entendido se guardan los archivos de 64 bits que se llama solamente "archivos del sistema" no hay nada relacionado a Realtek, esto me confunde, a lo mejor lo ignoro mucho, pero si estoy instalando drivers de 64 bits (ya que es de 64bits mi Windows) porque no se guardan aquí los drivers?

Estarán instalándose bien los drivers o que fallara? o me desvié del problema? :?

De antemano muchísimas gracias, al menos ya he aprendido muchas cosas en este trayecto, Ojala haya alguna solución... Saludos

Avatar de Usuario
pako
Usuario Bill Gates
Usuario Bill Gates
Mensajes: 1140
Registrado: 08 Jun 2018, 19:40

Re: No detecta salida de audio desde la placa base ni detecta dispositivos de audio

Mensaje por pako »

Hola,

Vamos por partes, porque creo que con algunas cosas te liás o no te entiendo yo bien.

Windows no puede usar una pieza de hardware sin mas, necesita un driver para poder "charlar" y comunicarse con esa pieza.
Por ejemplo, para comunicarnos tu y yo usamos el lenguaje español, pues ese idioma seria el driver.

Ahora que Windows ya tiene el driver, otros programas ya pueden usar esa pieza y decirle que ordenes hacer.
Volviendo al ejemplo anterior, ahora que los dos hablamos el idioma español, yo podría ordenarte que me digas las especificaciones de tu PC y como hablamos el mismo idioma (driver) podríamos comunicarnos.

Entendido el concepto de programas y drivers, decirte que ambos se guardan en rutas distintas y en el caso de los programas dependerá si son de 32 o 64 bits.

Ruta de programas de 32 bits:
C:\Program Files (x86)

Ruta de programas de 64 bits:
C:\Program Files

Hoy en día ya la mayoría de programas son de 64 bits, pero hay programas que son antiguos o que no merecen la pena actualizarlos y siguen siendo de 32 bits, pero podemos usarlos en equipos de 64 bits.

En esas dos rutas se guardan los programas, los drivers que se instalan en Windows se guardan en la carpeta:
C:\Windows\System32\DriverStore

Es cierto como dices que en esas dos carpetas para programas de 32 y 64 bits pueda aparecer en su interior una que se llame drivers, pero es solo para instalarlo y poder darle a Windows el driver, o para el día de mañana si quieres reinstalar porque de fallos el programa también guarda ahí el driver para poder reinstalarlo, etc.

Una vez instalado el driver, para saber que esta bien hay que ir al administrador de dispositivos, allí marca con una admiración cuando esta mal, si esta bien... doble clic sobre el que quieres comprobar (Realtek High Definition Audio) y en la ventana que abre en estado de dispositivo pondrá "Este dispositivo funciona correctamente".

A groso modo seria así como funciona tema drivers y programas.

**********

En tu caso concreto, lo que pretendía es que instales el programa de Realtek para configurar la tarjeta de sonido.
Desde la tienda no te deja, dices que tienes el mismo problema con el que te dije de la pagina de Realtek, que significa eso? te dejo instalar el programa? no te dejo? de ser así que código de error te dio?

En mi caso también tengo Realtek pero mas antigua, tu tienes ALC1220 y yo ALC1150, yo cuando instalo el programa me lo mete en la ruta:
C:\Program Files\Realtek\Audio\HDA
Allí entre otras cosas tengo un ejecutable que es:
RtkNGUI64.exe

Y me abre la aplicación de Realtek:

Imagen

Tu deberías de tener un programa mas moderno y con mas opciones de Realtek.

Y que lo metieras es porque de primeras te instala el driver de Realtek y no el de Windows, por otro lado en el programa abajo se ven los colores de las conexiones de los altavoces, en alguna de ellas puedes pulsarlas y cambiar por ejemplo una entrada de linea por una salida de altavoces.

**********

Sobre tus carpetas...

Yo también tengo el "Rtkupd64" que comentas, pero ese es para actualizar o quitar el driver, el que deberías de tener y ejecutar es el que esta al lado con el icono del altavoz.

Imagen

El de "dragón" es para mejorar las latencias, es para gamers mas que nada.

El de "NICDRV_8169" entiendo que es el driver que uso para instalarlo.

**********

Vete a las rutas:
C:\Program Files\Realtek\Audio\HDA
C:\Program Files (x86)\Realtek\Audio\HDA

Y comprueba si allí tienes el ejecutable:

RtkNGUI64.exe

Y como te decía antes, dime que error te salio al instalar el programa de Realtek que te pase el link.

Saludos
Si has encontrado aquí la ayuda que esperabas (o incluso si no ha sido así ;) ), ayúdanos a mantener el foro con un pequeño donativo.
¡Muchas gracias!

ang04
Usuario linuxero
Usuario linuxero
Mensajes: 4
Registrado: 20 Jul 2021, 02:18

Re: No detecta salida de audio desde la placa base ni detecta dispositivos de audio

Mensaje por ang04 »

pako escribió: 22 Jul 2021, 11:03 Hola,

Vamos por partes, porque creo que con algunas cosas te liás o no te entiendo yo bien.

Windows no puede usar una pieza de hardware sin mas, necesita un driver para poder "charlar" y comunicarse con esa pieza.
Por ejemplo, para comunicarnos tu y yo usamos el lenguaje español, pues ese idioma seria el driver.

Ahora que Windows ya tiene el driver, otros programas ya pueden usar esa pieza y decirle que ordenes hacer.
Volviendo al ejemplo anterior, ahora que los dos hablamos el idioma español, yo podría ordenarte que me digas las especificaciones de tu PC y como hablamos el mismo idioma (driver) podríamos comunicarnos.

Entendido el concepto de programas y drivers, decirte que ambos se guardan en rutas distintas y en el caso de los programas dependerá si son de 32 o 64 bits.

Ruta de programas de 32 bits:
C:\Program Files (x86)

Ruta de programas de 64 bits:
C:\Program Files

Hoy en día ya la mayoría de programas son de 64 bits, pero hay programas que son antiguos o que no merecen la pena actualizarlos y siguen siendo de 32 bits, pero podemos usarlos en equipos de 64 bits.

En esas dos rutas se guardan los programas, los drivers que se instalan en Windows se guardan en la carpeta:
C:\Windows\System32\DriverStore

Es cierto como dices que en esas dos carpetas para programas de 32 y 64 bits pueda aparecer en su interior una que se llame drivers, pero es solo para instalarlo y poder darle a Windows el driver, o para el día de mañana si quieres reinstalar porque de fallos el programa también guarda ahí el driver para poder reinstalarlo, etc.

Una vez instalado el driver, para saber que esta bien hay que ir al administrador de dispositivos, allí marca con una admiración cuando esta mal, si esta bien... doble clic sobre el que quieres comprobar (Realtek High Definition Audio) y en la ventana que abre en estado de dispositivo pondrá "Este dispositivo funciona correctamente".

A groso modo seria así como funciona tema drivers y programas.

**********

En tu caso concreto, lo que pretendía es que instales el programa de Realtek para configurar la tarjeta de sonido.
Desde la tienda no te deja, dices que tienes el mismo problema con el que te dije de la pagina de Realtek, que significa eso? te dejo instalar el programa? no te dejo? de ser así que código de error te dio?

En mi caso también tengo Realtek pero mas antigua, tu tienes ALC1220 y yo ALC1150, yo cuando instalo el programa me lo mete en la ruta:
C:\Program Files\Realtek\Audio\HDA
Allí entre otras cosas tengo un ejecutable que es:
RtkNGUI64.exe

Y me abre la aplicación de Realtek:

Imagen

Tu deberías de tener un programa mas moderno y con mas opciones de Realtek.

Y que lo metieras es porque de primeras te instala el driver de Realtek y no el de Windows, por otro lado en el programa abajo se ven los colores de las conexiones de los altavoces, en alguna de ellas puedes pulsarlas y cambiar por ejemplo una entrada de linea por una salida de altavoces.

**********

Sobre tus carpetas...

Yo también tengo el "Rtkupd64" que comentas, pero ese es para actualizar o quitar el driver, el que deberías de tener y ejecutar es el que esta al lado con el icono del altavoz.

Imagen

El de "dragón" es para mejorar las latencias, es para gamers mas que nada.

El de "NICDRV_8169" entiendo que es el driver que uso para instalarlo.

**********

Vete a las rutas:
C:\Program Files\Realtek\Audio\HDA
C:\Program Files (x86)\Realtek\Audio\HDA

Y comprueba si allí tienes el ejecutable:

RtkNGUI64.exe

Y como te decía antes, dime que error te salio al instalar el programa de Realtek que te pase el link.

Saludos
Buen día, gracias por la orientación de como funcionan los programas y drivers y como se guardan, básicamente solo desconocía donde se guardaban realmente los drivers (en la dirección C:\Windows\System32\DriverStore) y ahora entiendo mejor como funcionan al instalarlos y como se identifican dependiendo de donde estén, gracias de nuevo.

************************
Ahora, sobre lo que ocurrió cuando descargue de <[Enlace externo eliminado para invitados]> e instale el zip "Win7_Win8_Win81_Win10_R282" y ejecute el "setup"...

Pues nada, pero permítame describir el acontecimiento: lo descargue (Tardo bastante a pesar de pesar poco, ni idea... Pero Descargue primero el zip comprimido y luego lo intente con el ejecutable) descomprimí el zip, entre a la carpeta y le di al setup... Efectivamente sale lo siguiente:



Para después salir:



Después le doy siguiente y al final sale esto:



Desde este momento le doy "Finalizar" y hace lo que tiene que hacer... Después de esto viene la parte a la que me refiero donde realmente digo que no cambio absolutamente nada.

Reinicia la PC, entro y vaya, efectivamente, en programas esta instalado el driver de audio de Realtek pero, sin embargo, en las carpetas que comentaba en mi respuesta anterior, en "C:\Program Files" la carpeta de Realtek es inexistente, como si no se hubiera instalado nada o como si hubiera desaparecido :? ... en "C:\Program Files (x86)" efectivamente, si se encuentra una carpeta de Realtek pero como mostré en las imágenes de mi respuesta anterior, solo me aparecen los archivos que ahí se muestran, no me parecen los que tu tienes en imagen y menos el altavoz para abrir ese programa que también muestras... además de que, como dato, en "administrador de dispositivos" igualmente sigue sin aparecer un controlador de Realtek para manejar los dispos de audio... No sé que puede ser la confusión o si no me doy a explicar :( espero realmente se entienda está parte y solo sea la confusión del porque sucede esto a pesar de "instalar" el controlador... Básicamente, los archivos que tienes en tu imagen a mi no me aparecen, solamente el único ya mencionado, no tengo el archivo "RtkNGUI64.exe" cuando efectivamente en el Zip que descargue (del enlace que enviaste) si aparece pero instalo con el "setup", reinicia, y no sale más que lo que ya había comentado y mandado en imágenes anteriormente

No sé que pueda estar sucediendo pero describí lo que ocurrió y a que me refería con la expresión de que no ocurría nada, no es que me salga un error, es que realmente parece que instala lo que tiene que instalar pero al reiniciarse el PC y abrir o buscar lo que necesito no está, solo los archivos que salen en las imágenes que había mandado :(

Ojala haya una razón coherente de porque pasa esto, muchas gracias por tu apoyo, de nuevo saludos y ¿Qué opinas?...