Problema con lector DNIe (Solucionado)

Foro referente al sistema operativo Windows XP
Yomismo
Usuario linuxero
Usuario linuxero
Mensajes: 7
Registrado: 17 Ago 2010, 19:18
Ubicación: Castellón
Contactar:

Problema con lector DNIe (Solucionado)

Mensajepor Yomismo » 17 Ago 2010, 19:28

Saludos a todos,

Acabo de adquirir un lector de tarjetas para el DNIe.
Es el EZ100PU Smart Card Reader de Activbb.
Pues bien lo tengo todo instalado pero no hay comunicación con el ordenador. :?:

En Panel de control/Sistema/Hardware/Administrador de dispositivos/Lectoras de tarjetas inteligentes SÍ que me aparece y me dice que está todo correcto, pero en
Panel de control/Herramientas Administrativas/Servicios/Servicios locales NO está. :?:

Lleva un programa de chequeo donde me dice lo siguiente:

Diagnose Current Smart Card System v1.9
==========================================================================

OS Version : Windows XP Home Edition Service Pack 3 (build 2600)
Computer Name : LUIS-7EAEE861C3
Date : 2010/08/17, Tuesday
Time : PM 07:00:00
User Name : Luis

==========================================================================

1. Smart Card Base Component Verification
Resource Manager(5.1.2600.5512).......................PASSED
Smart Card Library(5.1.2600.0).....................PASSED

2. Smart Card Service Activation
SCARDSVR.EXE........................................FAILED

3. Reader Driver Installation
EZUSB.SYS(3.1.7)...................................PASSED
EZUSB.INF..........................................PASSED

4. Reader Registration
.....................SMART CARD BASE COMPONENT NOT ACTIVE

Some of PC/SC Smart Card Environment Failed.


En un .pdf de FAQ que trae vienen frases como:
System privilege is not satisfied
Please make sure you have the same privilege with Administrator

Es como si tuviera que tener los mismos permisos que un administrador para poder instalarlo, o algo asi ¿no?.
Pero mi cuenta de usuario "Luis" es administrador según Panel de control/Cuentas de usuario.
No lo entiendo.

Mis conocimientos de informática son muy básicos.
Yo no se que hacer. :?:
Necesito vuestra ayuda, por favor.
Gracias

Avatar de Usuario
Souto
Usuario Bill Gates
Usuario Bill Gates
Mensajes: 10665
Registrado: 25 Feb 2008, 10:21
Ubicación: Galicia
Agradecido : 6 veces
Agradecimiento recibido: 647 veces
Contactar:

Re: Problema con lector DNIe

Mensajepor Souto » 17 Ago 2010, 20:01

Hola, bienvenido.
La verdad es que para ser un usuario "flojito" el diagnóstico que has realizado es impecable.
Da la impresión de que , no ya tu cuenta de administrador, sino incluso la cuenta System han sido degradadas a la hora de manejar el componente Services.
Vamos a ir al Registro (no te preocupes, no cambiaremos nada)
Inicio /Ejecutar: regedit
en la ventana de la izquierda vete pulsando sobre la + para expandir esta ruta
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SCardSvr
haz ratón derecho sobre SCardSvr y da en "Permisos", se abrirá una ventana similar a esta

Imagen


pulsa arriba sobre administradores para resaltarlo y mira abjo que permisos tiene (control totat, leer, perm especiales). A continuación pulsa sobre System y mira también que permisos tiene.
Coméntanos el resultado.

Saludos

Saludos
Qui dove il mare luccica e tira forte il vento

Yomismo
Usuario linuxero
Usuario linuxero
Mensajes: 7
Registrado: 17 Ago 2010, 19:18
Ubicación: Castellón
Contactar:

Re: Problema con lector DNIe

Mensajepor Yomismo » 18 Ago 2010, 10:41

Hola,
Gracias por la rápida respuesta.
En HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SCardSvr tengo:

Imagen


¿No hay demasiados LUIS-7E....C3?. :?: Uno es \Administradores, otro \Luis y el otro \Usuarios. :?:

Permisos
- En Administadores: ya veis la imagen
- Luis (LUIS-.......\Luis): No tiene ningñun permiso
- System: como la imagen
- Usuarios: solo está marcado Permitir Leer.

Un Saludo

Avatar de Usuario
Souto
Usuario Bill Gates
Usuario Bill Gates
Mensajes: 10665
Registrado: 25 Feb 2008, 10:21
Ubicación: Galicia
Agradecido : 6 veces
Agradecimiento recibido: 647 veces
Contactar:

Re: Problema con lector DNIe

Mensajepor Souto » 18 Ago 2010, 19:30

LUIS con mayúsculas sí tiene los permisos (aparece velado, pero está marcado) y también System (que es lo más importante) tiene esos permisos. No se explica por lo tanto porqué no se puede modificar esa clave del Registro.

Mi propuesta es esta:
1. Asegúrate de que lo de los permisos está bien. Para ello bastará con que ejecutes este Fix it
http://support.microsoft.com/kb/313222/es
2. Reiniciado el equipo, vuelve a instalar la aplicación para el lector DNI y si continúa el problema yo crearía un punto de restauración manual (Inicio/Programas/Accesorios/herramientas del../Restaurar sistema/Crear un punto..) y seguidamente forzaría la instalación del software con esto que te pongo a continuación. No sé hasta que punto será comprensible para tí: si necesitas detalles, me lo indicas.

http://wiki.answers.com/Q/How_do_I_forc ... rt_message

Saludos
Qui dove il mare luccica e tira forte il vento

Yomismo
Usuario linuxero
Usuario linuxero
Mensajes: 7
Registrado: 17 Ago 2010, 19:18
Ubicación: Castellón
Contactar:

Re: Problema con lector DNIe

Mensajepor Yomismo » 19 Ago 2010, 11:14

Buenas,
- Tras ejecutar el Fix it y reiniciar -> Todo sigue igual. No ha funcionado.
- En cuanto a la segunda opción tengo algunas dudas:

1.- Ya he creado los archivos SCARD_XP.CMD y SCARD_XP.REG

2.- Los tengo que ejecutar con el lector instalado y reiniciar ??

3.- O los ejecuto, reinicio e instalo el lector ??

4.- En el SCARD_XP.REG solo he puesto
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Servic es\SCardSvr]
"ObjectName"="NT AUTHORITY\\LocalService"
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Servic es\SCardDrv]
"ObjectName"="NT AUTHORITY\\LocalService"

Lo de Windows Registry Editor Version 5.00 no lo he incluido ¿correcto,no?

- Otra duda: En el CD de instalación vienen varios ejecutables segun el S.O., el que ejecuto es el del XP2003.
Yo tengo en XP2002 SP3. ¿Puede haber ahí algún problema?

Muchas Gracias

Avatar de Usuario
Souto
Usuario Bill Gates
Usuario Bill Gates
Mensajes: 10665
Registrado: 25 Feb 2008, 10:21
Ubicación: Galicia
Agradecido : 6 veces
Agradecimiento recibido: 647 veces
Contactar:

Re: Problema con lector DNIe

Mensajepor Souto » 19 Ago 2010, 15:26

Lo de Windows Registry Editor Version 5.00 no lo he incluido ¿correcto,no?

No, debes incluir también la cabecera
Es idiferente que el lector esté ó no instalado.

La propuesta de ese hombre (en lo que yo alcanzo) es forzar la instalación completa del programa desde ms-dos para impedir que actúe ningún tipo de limitación. Esto es lo que hará el SCARD_XP.CMD, una reinstalación en modo "force"
A continuación, para obviar cualquier limitación en el Registro, se crean manualmente (ó se sobreescriben con los valores correctos) las entradas que el programa de instalación debería haber generado. Esto es lo que pasará cuando hagas doble clic sobre SCARD_XP.REG

Otra duda: En el CD de instalación vienen varios ejecutables segun el S.O., el que ejecuto es el del XP2003.
Yo tengo en XP2002 SP3. ¿Puede haber ahí algún problema?

No, en absoluto.

Por último, añadir, que no asumes riesgo alguno por probar esa solución. En cualquier caso, si tampoco va, debes plantearte que un cortafuegos de terceros (el del antivirus, por ejemplo) podría estar detrás de todo esto.

Saludos
Qui dove il mare luccica e tira forte il vento

Yomismo
Usuario linuxero
Usuario linuxero
Mensajes: 7
Registrado: 17 Ago 2010, 19:18
Ubicación: Castellón
Contactar:

Re: Problema con lector DNIe

Mensajepor Yomismo » 19 Ago 2010, 18:04

Hola,
Acabo de hacer lo que has dicho y ....

Diagnose Current Smart Card System v1.9
==========================================================================

OS Version : Windows XP Home Edition Service Pack 3 (build 2600)
Computer Name : LUIS-7EAEE861C3
Date : 2010/08/19, Thursday
Time : PM 06:27:43
User Name : Luis

==========================================================================

1. Smart Card Base Component Verification
Resource Manager(5.1.2600.5512).......................PASSED
Smart Card Library(5.1.2600.0).....................PASSED


2. Smart Card Service Activation
SCARDSVR.EXE........................................PASSED


3. Reader Driver Installation
EZUSB.SYS(3.1.7)...................................PASSED
EZUSB.INF..........................................PASSED

4. Reader Registration
SCardEstablishContext Fail : 0x8010001D
No Permission to Use Smart Card Service
...................................................FAILED

5. Communication with Reader (First)
EZUSB-EZ 100 PU : Reader Not Found
...................................................FAILED


Some of PC/SC Smart Card Environment Failed.


Algo hemos mejorado:
El pto 2 lo pasamos pero sigo sin comunicación con el aparatito de las narices.
En Panel de control/Herramientas Administrativas/Servicios/Servicios locales YA aparece
Estado: Iniciado
Tipo de Inicio: Automático
Iniciar sesión como: Sistema Local.

Para comprobar que no me está fastidiando el antivirus (tengo el Kaspersky Anti-Virus 2011) ¿cómo lo hago?
Desinstalo el lector, ejecuto el .cmd y reg. de nuevo, reinicio, desconecto el Antivirus e instalo el lector???

Gracias

Avatar de Usuario
Souto
Usuario Bill Gates
Usuario Bill Gates
Mensajes: 10665
Registrado: 25 Feb 2008, 10:21
Ubicación: Galicia
Agradecido : 6 veces
Agradecimiento recibido: 647 veces
Contactar:

Re: Problema con lector DNIe

Mensajepor Souto » 19 Ago 2010, 22:50

Tómatelo con calma porque esto va para largo: aparentemente sí tiene que ver con permisos y sí tiene que ver con la versión de XP que estás usando.
Vuelve a realizar ratón derecho>>permisos sobre estas otras claves

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Cryptography\Calais

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurePipeServers\winreg

si bien en este caso no te aparecerán como antes todos los usuarios. Tan sólo verás ADMINISTRADORES y Servicio Local. Pulsa sobre Servicio local para resaltarlo y compruena que en ambos casos tenga marcado "Control total". De no ser así, haz el cambio, cierra el editor del Registro y reinicia el equipo.

http://support.microsoft.com/kb/832082

Saludos
Qui dove il mare luccica e tira forte il vento

Yomismo
Usuario linuxero
Usuario linuxero
Mensajes: 7
Registrado: 17 Ago 2010, 19:18
Ubicación: Castellón
Contactar:

Re: Problema con lector DNIe

Mensajepor Yomismo » 20 Ago 2010, 17:47

Hola Souto,
¡¡ Todo sigue igual !!, es decir, ¡¡ mal !!

Antes de hacer lo que me dijiste lo desinstalé.
Después de reiniciar lo volví a instalar y lo de siempre:

4. Reader Registration
SCardEstablishContext Fail : 0x8010001D
No Permission to Use Smart Card Service
...................................................FAILED
5. Communication with Reader (First)
EZUSB-EZ 100 PU : Reader Not Found
...................................................FAILED


Incluso probé en HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Cryptography\Calais al Usuarios (LUIS-7EAEE861C3\Usuarios) a darle control total y... tampoco.

He buscado en el google el error 0x8010001D y solo sale una sola entrada, un pdf en "noruego" ¡¡Toma Ya!!.

Si cambio el lector por otro ¿seguiré teniendo el mismo problema?. Por acercarme este finde a MediaMarkt decir que no funciona y coger otro de otra marca.

Lo que has comentado del XP, el mio es original. Me lo dieron con el PC. Tengo el CD y todo. Tengo activadas las actualizaciones automaticas y cada dos por tres se actualiza. Te lo comento por si fuera importante.

Saludos y gracias, muchas gracias por tu ayuda.

Yomismo
Usuario linuxero
Usuario linuxero
Mensajes: 7
Registrado: 17 Ago 2010, 19:18
Ubicación: Castellón
Contactar:

Re: Problema con lector DNIe

Mensajepor Yomismo » 20 Ago 2010, 19:52

Hola Souto de nuevo,

YA FUNCIONA :lol: :lol: :lol:
Yomismo escribió:
He buscado en el google el error 0x8010001D y solo sale una sola entrada, un pdf en "noruego" ¡¡Toma Ya!!.


Pues bien en el pdf este en noruego las dos primeras hojas:
Imagen
Imagen
He seguido los pasos, siguiendo las fotos se entendía mas o menos, y al colocar lo del NT AUTHORITY\LocalService pues

Diagnose Current Smart Card System v1.9
==========================================================================

OS Version : Windows XP Home Edition Service Pack 3 (build 2600)
Computer Name : LUIS-7EAEE861C3
Date : 2010/08/20, Friday
Time : PM 08:43:49
User Name : Luis

==========================================================================

1. Smart Card Base Component Verification
Resource Manager(5.1.2600.5512).......................PASSED
Smart Card Library(5.1.2600.0).....................PASSED

2. Smart Card Service Activation
SCARDSVR.EXE........................................PASSED

3. Reader Driver Installation
EZUSB.SYS(3.1.7)...................................PASSED
EZUSB.INF..........................................PASSED

4. Reader Registration
Name0 : CASTLES EZ100PU 0
...................................................PASSED

5. Communication with Reader (First)
(Card Absent).......................................PASSED


PC/SC Smart Card Environment is proper(OK).


¿Por qué?. Pues no lo sé.
Espero que no me interfiera en otros procesos.
La explicación te la dejo a tí, que me has demostrado que eres un crack.

Mañana lo probaré todo bien con el DNIe y te comentaré los resultados (ahora no puedo)

Saludos, te informo...


Volver a “Windows XP / X64”

¿Quién está conectado?

Usuarios navegando por este Foro: Bing [Bot] y 2 invitados