No me detecta la unidad de cd-rom. (Solucionado)

Foro referente al sistema operativo Windows XP
paulo75
Usuario linuxero
Usuario linuxero
Mensajes: 22
Registrado: 26 Dic 2008, 19:25
Contactar:

Re: No me detecta la unidad de cd-rom.

Mensajepor paulo75 » 31 Mar 2009, 18:46

Haber, he arrancado con el cd de arranque de windows XP tal y como me ha indicado el Sr. Souto, y si que me funciona, és decir me pone un mensaje que me dice "pulsa cualquier tecla para iniciar desde CD"... y de paso, al ver que se podia iniciar desde el CD, he reinstalado Windows XP, por si fuera el caso que con esto se solucionaría pero nada de nada... sigue igual después de reinstalarlo.
En conclusión, que el problema està una vez tengo abierto Windows XP en el escritorio, o sea lo normal, igual que antes de la reinstalacion, no me detecta la unidad de CD/DVD, y és un problemón, porque ahora he tenido que instalar un antivirus gratuito (AVG-Anti-virus-Free), ya que no puedo instalar ningundo de los antivirus que tengo en casa, ni el Kaspersky, ni el Norton, ya que necessito insertar el CD para instalarlos, y claro, como no me lo detecta, no hay manera de poder ejecutar el instalador de alguno de estos dos antivirus, tan solo el gratuito que lo he podido bajar de internet...

En fin, provaré lo que me ha indicado "Papi", revisaré que las conexiones con la unidad de la lectora sean correctos, aún que creo que si con el disco de arranque me lo detecta, dudo que las conexiones puedan estar mal.

Si tienen alguna otra idea de donde puede venir el problema, les estaré muy agradecidos!

Gracias de nuevo.

GNU/Linux
Usuario linuxero
Usuario linuxero
Mensajes: 8
Registrado: 31 Mar 2009, 22:05
Contactar:

Re: No me detecta la unidad de cd-rom.

Mensajepor GNU/Linux » 31 Mar 2009, 22:24

hola paulo
mira fijate en lo siguiente, observa si tu unidad optica aparece en el administrador de dispositivos (accedes dandole click derecho a mi pc y luego a propiedades, ahi hay una ficha que dice hardware, la pinchas y luego das click en el boton administrador de dispositivos ahi existe un apartado que dice unidades de dvd/cd-rom) si es asi, vasta con que actualices los drivers de tu unidad (puede ser que lo allas volado por error o pudo ser un virus), si aun asi sigue sin funcionar, te recomiendo que hagas un respaldo y la formatees para evitarnos de tantos procedimientos XD, en dado caso de que el administrador de dispositivos no lo reconosca se tendria que abrir tu maquina y verificar que el lector este correctamente conectado (te recomiendo que lo lleves a un centro de reparacion autorizado si ere usuario final). De cualquier manera mantenos informados acerca del problema, pero primero prueba lo del administrador de dispositivos y me avisas...
salu2

Avatar de Usuario
Souto
Usuario Bill Gates
Usuario Bill Gates
Mensajes: 10665
Registrado: 25 Feb 2008, 10:21
Ubicación: Galicia
Agradecido : 6 veces
Agradecimiento recibido: 647 veces
Contactar:

Re: No me detecta la unidad de cd-rom.

Mensajepor Souto » 31 Mar 2009, 22:30

En fin, provaré lo que me ha indicado "Papi", revisaré que las conexiones con la unidad de la lectora sean correctos, aún que creo que si con el disco de arranque me lo detecta, dudo que las conexiones puedan estar mal

Esto ya no es necesario.
Mi propuesta y la de Papi eran diferentes vías para confirmar algo que ahora ya está claro: el cdrom no solo está correctamente conectado, sino que funciona perfectamente.
Para mi está claro que el tema tiene que estar entonces en una adulteración del registro ó en una configuración de la unidad como "oculta".
Vamos, si te parece, a realizar dos comprobaciones


A) COMPROBANDO EL ESTADO DE LA UNIDAD:
Inicio/Ejecutar: cmd
en la nueva ventana
diskpart
y a continuación
list vol
ratón derecho sobre el marco superior de esa ventana>> Editar>>Seleccionar todo>>pulsa la tecla Intro y ya lo tendrás en el portapapeles. Pégalo en el foro.

B) COMPROBANDO POLITICAS DEL EXPLORADOR:
Copia en bloc de notas el texto que más abajo te pongo en azul. Guárdalo en Escritorio con cualquier nombre (explorador, por ejemplo); pero antes de dar en Guardar como pulsa sobre Tipo para que en lugar de *.txt muestre Todos los archivos. Ahora, ya sí, lo guardas como explorador.bat Doble clic sobre ese archivo, se abrirá un archivo de texto, copia su contenido y pégalo también en el foro

C:\Windows\system32\reg.exe query "HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer" /s >>explorer.txt
start notepad explorer.txt



Saludos
Qui dove il mare luccica e tira forte il vento

paulo75
Usuario linuxero
Usuario linuxero
Mensajes: 22
Registrado: 26 Dic 2008, 19:25
Contactar:

Re: No me detecta la unidad de cd-rom.

Mensajepor paulo75 » 31 Mar 2009, 23:21

En el administrador de dispositivos no me aparece "unidades de dvd/cd-rom", tan solo me aparece "unidades de disco", y en ello el disco duro pero nada más, les dejo el enlace para que lo puedan ver: http://www.subirimagenes.com/otros-admi ... 64590.html

En cuanto a las comprobaciones que me ha recomendado de hacer el Sr.Souto, aqui teneis los resultados:
A)COMPROBAR EL ESTADO DE LA UNIDAD

Microsoft Windows XP [Versión 5.1.2600]
(C) Copyright 1985-2001 Microsoft Corp.

C:\Documents and Settings\Pau>diskpart

Microsoft DiskPart versión 5.1.3565

Copyright (C) 1999-2003 Microsoft Corporation.
En el equipo: PAU1

DISKPART> list vol

Volumen ### Etiqueta Ltr Fs Tipo Tamaño Estado Info
---------- --- ----------- ----- ---------- ------- --------- --------
Volumen 0 C NTFS Partición 75 GB Correcto Sistema


DISKPART>


B)COMPROBANDO POLITICAS DEL EXPLORADOR

! REG.EXE VERSION 3.0

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
NoDriveTypeAutoRun REG_DWORD 0x91






--------------------------------------------------------------------------------------


Bueno, que sepan que les estoy muy agradecido por la rápida atención que me estan prestando con este tema. Un saludo y haber si tiene arreglo.

GRACIAS!

saulitoooo
Usuario linuxero
Usuario linuxero
Mensajes: 4
Registrado: 01 Abr 2009, 01:30
Contactar:

Re: No me detecta la unidad de cd-rom.

Mensajepor saulitoooo » 01 Abr 2009, 02:30

HOLA AMIGO SABES VEO QUE TIENES MUCHOS PROBLEMAS CON TU LECTORA PRUEBA CON CUALQUIERA DE ESTOS DETALLES:

A)SI PUEDES ABRIR TU PC, REBIZA SI EL CABLE IDE O SATA ESTA EN PERFECTAS CONDICIONES(puedes conectarlo por un moneto a tu disco duro y ver si arranca normal)
CARGA TU SISTEMA OPERATIVO Y PRUEBA(si se cuelga de la nada tu sistema operativo tu cable ide o Sata esta mal).

B)ENTRA A TU SETUP(presiona F1 ó F2 ó Supr) DEPENDE DE QUE PLACA MADRE TENGAS, Y FIJATE SI LO ESTA DETECTANDO O NO(en la opcion ADVANCED), Y PORSIACASO HAZLO QUE ARRANQUE(boot) PRIMERO. Y CARGA TU SISTEMA OPERATIVO Y PRUEBA.

C)ENTRA A TU SETUP Y BUSCA LA OPCION "LOAD OPTIONAL DEFAULT" (esto se encargara de cargar todos los valores del fabricante por defecto para que carge todos los dispositivos de la placa) PRESIONAS "Y" PARA ACEPTAR Y SALES DEL SETUP GUARDANDO LOS CAMBIOS.SE CARGARA EL SISTEMA OPERATIVO Y DEBERIA RECONOCERTE LA LECTORA.

D)UNA OPCION SENCILLA SERIA FORMATEAR TU PC, Y SI FORMATEAS Y AUN SIGUE EL PROBLEMA DEFINITIVAMENTE SERIA TU LECTORA QUE ESTA EN MAL ESTADO(una vez le paso a mi amigo,el se compro una Pc nueva y al mes tenia el mismo problema con su Lectora, y como tenia garantia lo llevo a la tienda donde lo compro y le dijeron que ese tipo de lectora habian venido falladas era una "LG DVD-RW")

ESPERO HABERTE AYUDADO CON ESE PROBLEMA CUALQUIER DUDA PASAME LA VOZ MI CORREO ES yonathan_2003_15@hotmail.com BYE

Avatar de Usuario
Souto
Usuario Bill Gates
Usuario Bill Gates
Mensajes: 10665
Registrado: 25 Feb 2008, 10:21
Ubicación: Galicia
Agradecido : 6 veces
Agradecimiento recibido: 647 veces
Contactar:

Re: No me detecta la unidad de cd-rom.

Mensajepor Souto » 01 Abr 2009, 08:51

Copia en bloc de notas el texto que más abajo te pongo en azul. Guárdalo en Escritorio con cualquier nombre (reparar, por ejemplo); pero antes de dar en Guardar como pulsa sobre Tipo para que en lugar de *.txt muestre Todos los archivos. Ahora, ya sí, lo guardas como reparar.reg. Doble clic sobre ese archivo, aceptas, reinicias el equipo y a ver si hubo suerte.

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]
"CDRAutoRun"=dword:00000000
"LinkResolveIgnoreLinkInfo"=dword:00000000
"NoInstrumentation"=dword:00000000
"NoDrives"=dword:00000000
"NoStartBanner"=hex:00,00,00,00
"NoDriveTypeAutoRun"=dword:00000004
"NoViewContextMenu"=dword:00000000
"NoSaveSettings"=dword:00000000
"NoDriveAutoRun"=dword:ffffffdf

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer\Run]
Qui dove il mare luccica e tira forte il vento

paulo75
Usuario linuxero
Usuario linuxero
Mensajes: 22
Registrado: 26 Dic 2008, 19:25
Contactar:

Re: No me detecta la unidad de cd-rom.

Mensajepor paulo75 » 01 Abr 2009, 09:59

Cuando he clicado sobre el archivo "reparar.reg", primer me ha salido el siguiente mensaje:

"Esta seguro de que desea agregar la información en C:\Documents and Settings\Pau\Escritorio\reparar.reg al Registro?

Yo, le he dicho que si, pero al momento me sale otro mensaje de error del "editor del registro" que me indica lo siguiente:

"No se puede importar C:\Documents and Settings\Pau\Escritorio\reparar.reg: el archivo especificado no es una secuencia de comandos del Registro. Solo pude importar archivos binarios de Registro des de el editor de Registro".

Yo creo que no he hecho nada mal... primero he pegado el texto en azul en el bloc de notas, lo he guardado en el escritorio con la extensión .reg en todos los archivos, y luego he clicado dos veces sobre el para que se abriera, pero una vez le he confirmado que quería agregar la información al Registro, me ha salido el error.

Bueno, probaré alguna de las cosas que me ha indicado Saulitoooo.



Muchas gracias por todo! Haber si hay alguna solucion más. Tengo la esperanza ;)

Avatar de Usuario
Souto
Usuario Bill Gates
Usuario Bill Gates
Mensajes: 10665
Registrado: 25 Feb 2008, 10:21
Ubicación: Galicia
Agradecido : 6 veces
Agradecimiento recibido: 647 veces
Contactar:

Re: No me detecta la unidad de cd-rom.

Mensajepor Souto » 01 Abr 2009, 10:16

Lo has hecho correctamente. Prueba modificando la primera línea del .reg. Quedaría así:

REGEDIT4

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]
"CDRAutoRun"=dword:00000000
"LinkResolveIgnoreLinkInfo"=dword:00000000
"NoInstrumentation"=dword:00000000
"NoDrives"=dword:00000000
"NoStartBanner"=hex:00,00,00,00
"NoDriveTypeAutoRun"=dword:00000004
"NoViewContextMenu"=dword:00000000
"NoSaveSettings"=dword:00000000
"NoDriveAutoRun"=dword:ffffffdf

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer\Run]



Saludos
Qui dove il mare luccica e tira forte il vento

paulo75
Usuario linuxero
Usuario linuxero
Mensajes: 22
Registrado: 26 Dic 2008, 19:25
Contactar:

Re: No me detecta la unidad de cd-rom.

Mensajepor paulo75 » 01 Abr 2009, 10:48

Ahora si que lo he podido introducir en el Registro, ya que me ha saildo un mensaje que me ha indicado lo siguiente: "Se ha conseguido introducir la información de C:\Documents and settings\...etc" en el registro.
He reiniciado, pero nada de nada. Sigue igual, no lo detecta, hace el ruido como si se fuera a ejecutar, pero se para, y en mi pc no sale la unidad DVD/CD-ROM.

Seguiré esperando más ayudas :)

GRACIAS A TODOS!

paulo75
Usuario linuxero
Usuario linuxero
Mensajes: 22
Registrado: 26 Dic 2008, 19:25
Contactar:

Re: No me detecta la unidad de cd-rom.

Mensajepor paulo75 » 01 Abr 2009, 17:25

Buenas!!! se ha SOLUCIONADO! ya me detecta la unidad DVD/RW :)
Lo que he hecho ha sido arrancar con el CD de instalación de Windows XP, una vez me he encontrado en el menú de la instalación, he pulsado F3 para salir, y se ha reiniciado el PC otra vez, pero en esta segunda vez no he iniciado desde el CD, y de pronto, una vez en el escritorio, he entrado a "MIPC", y sorpresa! he visto como tenia la unidad de CD!
Después lo he vuelto ha reiniciar y ya no estaba XD... así que he reiniciado nuevamente con el CD de arranque de Windows para ver si se repetia el "milagro", y he seguido el mismo procedimiento (una vez en el menú de instalación, he puslado F3 para salir, y se ha reiniciado), y fuala! ya volía a tener la unidad de CD/DVD... A partir de este reinicio, ya me ha aparecido la unidad sin arrancar desde el CD de instalación, y he podido instalar el Norton :) Vamos, que ya funciona!
Ahora he puesto un acceso directo a la unidad CD/DVD en el escritorio XD... por si se va de "MI PC"...

EN FIN, QUE CON LA AYUDA DE TODOS VOSOTROS HE PODIDO AL FIN ARREGLAR MI UNIDAD LECTORA DE CD/DVD :):):)



MUCHÍSSIMAS GRACIAS ;)



VOY A RECOMENDAR ESTE FORO A TODO EL MUNDO QUE TENGA PROBLEMAS CON WINDOWS!



HASTA PRONTO!


Volver a “Windows XP / X64”

¿Quién está conectado?

Usuarios navegando por este Foro: No hay usuarios registrados visitando el Foro y 1 invitado