No lee dispositivos externos tras un cambio en el Registro

Foro referente al sistema operativo Windows XP
acastellon
Usuario linuxero
Usuario linuxero
Mensajes: 3
Registrado: 29 Feb 2008, 12:28
Contactar:

No lee dispositivos externos tras un cambio en el Registro

Mensajepor acastellon » 29 Feb 2008, 12:50

Hola a todos.
Hace unos días, en una revisión rutinaria de la presencia de virus con el Norton 2003, me apareció un mensaje de detección de un virus que no se pudo eliminar. En la hoja web de symantec donde se explica la forma de proceder ante ese virus, me indicaba que había de repetir el escaneo en Modo Seguro y que hiciese previamente una copia de seguridad (backup) del Registro del Sistema. Así lo hice, utilizando la herramienta que aparece en la misma web. Después de hacer el nuevo escaneo y de eliminar las líneas del Registro que me recomendaban en la web (en particular HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\Windows\"load"), he comprobado que ahora no me lee los dispositivos externos de memoria en el puerto USB. He intentado la restauración del Registro a partir de su backup(SYM_REGISTRY_BACKUP.reg) pero, después de una aparente carga normal, me sale el mensaje del Editor: "No se puede importar C:\SYM_REGISTRY_BACKUP.reg: No todos los datos se escribieron correctamente en el Registro. Algunas claves están abiertas por el sistemao u otros procesos".
¿Alguno de vosotros sabe que pasa? ?¿Cómo puedo restaurar el Registro?
Gracias.

Avatar de Usuario
Souto
Usuario Bill Gates
Usuario Bill Gates
Mensajes: 10665
Registrado: 25 Feb 2008, 10:21
Ubicación: Galicia
Agradecido : 6 veces
Agradecimiento recibido: 647 veces
Contactar:

Re: No lee dispositivos externos tras un cambio en el Registro

Mensajepor Souto » 29 Feb 2008, 13:04

Bienvenido al foro!!
El mensaje que recibes a la hora de cargar la copia del registro puede tener dos lecturas. La primera, que esa copia esté corrupta, es poco probable. La segunda, la más probable, sería que se quieren sobreescribir claves del registro que algún programa está usando (tiene abiertas) en ese momento.
Para solventarlo tendrás que pulsar F8 nada más encender el equipo y de las opciones de arranque que se te van a mostrar deberás elegir Modo seguro, entra con la cuenta Administrador y procede a restaurar el registro si ese es tu deseo.

En todo caso debieras plantearte hasta que punto te resulta conveniente restaurar un registro, que por lo que dices, contenía alguna entrada perjudicial.
De manera que según lo que acuerdes podemos, sin restaurar el registro, intentar solventar lo de las usb. En este último caso explica, por favor, si al insertarla es reconocida, se recibe algún mensaje ó simplemente el equipo no se entera ni tampoco aparece en MiPC. Además es conveniente que compruebes si en tu registro actual tienes un valor (ventana de la derecha) NoDrives en la clave:
HKEY CURRENT USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer


Saludos
Qui dove il mare luccica e tira forte il vento

acastellon
Usuario linuxero
Usuario linuxero
Mensajes: 3
Registrado: 29 Feb 2008, 12:28
Contactar:

Re: No lee dispositivos externos tras un cambio en el Registro

Mensajepor acastellon » 29 Feb 2008, 18:18

Hola Souto. Gracias por atender a mi problema.
La restauración (restore) del backup del Registro en Modo Seguro con todas las aplicaciones cerradas y el antivirus desactivado, ya la probé y no funcionó.
Lo que quiero hacer, restaurando el sistema a una posición anterior a la eliminación del virus, es recuperar la funcionalidad del puerto USB y proceder de nuevo a la eliminación del virus, pero sin tocar la línea ...\"load" del Registro que creo que es la que me ha creado este problema.
Si quieres podemos probar a resolver directamente el problema de los USB, aunque es posible que no sea el único problema que ha quedado tras la modificación del Registro. Actualmente, el equipo reconoce el dispositivo de almacenamiento introducido en el puerto USB y también aparece en MiPC, pero es incapaz de ver su contenido.
Ahora no estoy en este equipo y no puedo comprobar el valor NoDrives de la clave
HKEY CURRENT USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer, pero en cuanto lo tenga delante lo miro y te digo algo.

Saludos,

Avatar de Usuario
Souto
Usuario Bill Gates
Usuario Bill Gates
Mensajes: 10665
Registrado: 25 Feb 2008, 10:21
Ubicación: Galicia
Agradecido : 6 veces
Agradecimiento recibido: 647 veces
Contactar:

Re: No lee dispositivos externos tras un cambio en el Registro

Mensajepor Souto » 29 Feb 2008, 18:53

Si se ve el dispositivo en MiPC, ya no es preciso que busques ese valor en el Registro.
Has probado con la utilidad Restaurar sistema? debiera solucionar la situación.

Por otra parte, visto como están las cosas, la única forma de cargar con seguridad esa copia del Registro es desde la consola. Si no funciona Restaurar sistema, te explicaría el procedimiento.

Saludos
Qui dove il mare luccica e tira forte il vento

acastellon
Usuario linuxero
Usuario linuxero
Mensajes: 3
Registrado: 29 Feb 2008, 12:28
Contactar:

Re: No lee dispositivos externos tras un cambio en el Registro

Mensajepor acastellon » 29 Feb 2008, 20:08

Hola de nuevo Souto. Gracias por responder a mi problema.
No me sirve utilizar la utilidad porque, durante la eliminación del virus, desactive esa opción (recomendación de la hoja web de Symantec para ese virus) por lo que sólo pueddo Restaurar sistema hasta una fecha posterior a la modificación del Registro.
Tendrás que explicarme como se hace eso de cargar la copia desde la consola.

Saludos

Avatar de Usuario
Souto
Usuario Bill Gates
Usuario Bill Gates
Mensajes: 10665
Registrado: 25 Feb 2008, 10:21
Ubicación: Galicia
Agradecido : 6 veces
Agradecimiento recibido: 647 veces
Contactar:

Re: No lee dispositivos externos tras un cambio en el Registro

Mensajepor Souto » 10 Mar 2008, 12:01

Lamento que se me haya quedado descolgado tu tema.
En cuanto a esto:
Tendrás que explicarme como se hace eso de cargar la copia desde la consola.

Si has seguido los pasos de Symantec, esa copia no nos sirve para ser cargada desde la consola. Para este fin la copia debería haber sido creada con la utilidad Ntbackup del propio Xp. Mi consejo es que intentemos solucionar lo de los dispositivos externos: revisa los pasos que se han dado en este largo post y aporta un par de capturas con la opción mostrar dispositivos ocultos activada. Las capturas serían las de Controladores que no son Plug and Play y la de Volúmenes de almacenamiento.
Es posible que todo esto te suene a chino; pero leyendo el post ya lo comprenderás.

windows-xp-x64-f3/no-me-reconoce-discos-duros-externos-solucionado-t118.html

Saludos
Qui dove il mare luccica e tira forte il vento


Volver a “Windows XP / X64”

¿Quién está conectado?

Usuarios navegando por este Foro: Yahoo [Bot] y 6 invitados