AYUDA CON SERVICE PACK · Tema Solucionado

Foro referente al sistema operativo Windows XP
ajb1912
Usuario linuxero
Usuario linuxero
Mensajes: 11
Registrado: 07 Nov 2009, 14:12
Agradecido : 6 veces
Contactar:

AYUDA CON SERVICE PACK ·

Mensajepor ajb1912 » 05 May 2012, 11:29

Hola, supongo que este tema ya estará tratado pero os aseguro que he utilizado el buscador con los términos Service Pack3 y SP3 y no he encontrado respuesta.

Bueno la cuestión es que tengo un problema. He descargado el Service Pack3 para Windows XP 32 bits. El problema es que cuando le pincho a ejecutar me aparece un mensaje de error en la instalación. El mensaje dice: "No hay espacio en disco suficiente en C:\WINDOWS\$NTServicePackUninstall$ para instalar Service Pack 3. El programa necesita un mínimo de de 4 megabytes adicionales de espacio libre. Libere su disco duro y vuelva a intentarlo"

No puedo entenderlo porque tengo 140 Gb di disco duro disponible. También he intentado descomprimir el SP3 y ejecutarlo desde la carpeta Update de i386 pero me aparece el mismo error.

Por favor que alguien me ayude porque estoy desesperado.

Gracias

Avatar de Usuario
Souto
Usuario Bill Gates
Usuario Bill Gates
Mensajes: 10665
Registrado: 25 Feb 2008, 10:21
Ubicación: Galicia
Agradecido : 6 veces
Agradecimiento recibido: 647 veces
Contactar:

Re: AYUDA CON SERVICE PACK ·

Mensajepor Souto » 05 May 2012, 13:38

Hola,
Inicio/Ejecutar y ahí tecleas: cmd
en la nueva ventana pegas este comando y das intro
reg query "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Setup" >setup.txt
a continuación este otro y das intro
notepad setup.txt
se abrirá un texto, copia su contenido y lo pegas en el foro.


Saludos
Qui dove il mare luccica e tira forte il vento

ajb1912
Usuario linuxero
Usuario linuxero
Mensajes: 11
Registrado: 07 Nov 2009, 14:12
Agradecido : 6 veces
Contactar:

Re: AYUDA CON SERVICE PACK ·

Mensajepor ajb1912 » 05 May 2012, 19:38

Gracias Souto. Esto es lo que me ha salido después de seguir tus instrucciones:


! REG.EXE VERSION 3.0

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Setup
DriverCachePath REG_EXPAND_SZ %SystemRoot%\Driver Cache
PrivateHash REG_BINARY EB6A0AC606AFF8C5AB79DFCD85DCD2AE
Installation Sources REG_MULTI_SZ C:\Archivos de programa\Motorola\\0
SourcePath REG_SZ D:\
ServicePackSourcePath REG_SZ D:\
CDInstall REG_DWORD 0x1
LogLevel REG_DWORD 0x0
ServicePackCachePath REG_SZ c:\windows\ServicePackFiles\ServicePackCache

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Setup\BaseWinOptions

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Setup\ExceptionComponents

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Setup\Migration DLLs

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Setup\Oc Manager

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Setup\OOBE

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Setup\OptionalComponents

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Setup\WindowsFeatures


A ver si conseguimos algo

Gracias de nuevo

Avatar de Usuario
Souto
Usuario Bill Gates
Usuario Bill Gates
Mensajes: 10665
Registrado: 25 Feb 2008, 10:21
Ubicación: Galicia
Agradecido : 6 veces
Agradecimiento recibido: 647 veces
Contactar:

Re: AYUDA CON SERVICE PACK ·

Mensajepor Souto » 05 May 2012, 22:15

La configuración de esa clave del Registro es incorrecta.
Aparentemente el XP lo tienes en D: y por ahí no hay problema; pero la fuente de instalación es incorrecta (Installation Sources REG_MULTI_SZ C:\Archivos de programa\Motorola\\0)
y la unidad de driver caché también (c:\windows\ServicePackFiles\ServicePackCache)

Pero lo que realmente está impidiendo la instalación de SP es que falta en esa clave el valor BootDir, el cual necesariamente tendría que estar apuntando al volumen de XP.

Aclara si XP está en D: y, sobre todo, aclara qué es lo que tienes en C:(la situación es típica cuando compaginamos MacOS con XP)




Saludos
Qui dove il mare luccica e tira forte il vento

ajb1912
Usuario linuxero
Usuario linuxero
Mensajes: 11
Registrado: 07 Nov 2009, 14:12
Agradecido : 6 veces
Contactar:

Re: AYUDA CON SERVICE PACK ·

Mensajepor ajb1912 » 06 May 2012, 00:54

Bueno en la unidad D tengo el lector de CD pero sin disco ya que el SP3 es de una descarga. En C me aparece el disco duro en el que tengo instalado Windows pero, como tú dices, estoy trabajando con un mac, tengo instalados los dos sistemas operativos y no puedo ver dónde está instalado el OSX (soy muy torpe, lo siento) porque sólo trabajo con Windows pero, como te puedes imaginar, no puedo desinstalar el OSX de Mac ya que es la llave que me permitió instalar el Windows.

Muchas gracias por tu interés, espero tu ayuda.

Abraham

Avatar de Usuario
Souto
Usuario Bill Gates
Usuario Bill Gates
Mensajes: 10665
Registrado: 25 Feb 2008, 10:21
Ubicación: Galicia
Agradecido : 6 veces
Agradecimiento recibido: 647 veces
Contactar:

Re: AYUDA CON SERVICE PACK ·

Mensajepor Souto » 06 May 2012, 12:10

La causa de la incidencia está clara ya.
Falta el valor BootDir.
Se trata simplemente de agregarlo a esa clave.En tanto que no pareces muy puesto en la materia, te facilito la tarea.Aprovecharemos también la ocasión para ajustar otros dos valores.

Copia en bloc de notas el texto que más abajo te pongo en azul. Guárdalo en Escritorio con cualquier nombre (reparar, por ejemplo); pero antes de dar en Guardar como pulsa sobre Tipo para que en lugar de *.txt muestre Todos los archivos. Ahora, ya sí, lo guardas como reparar.reg. Si lo has hecho bien se mostrará así:

Imagen




Doble clic sobre él y aceptas que se agregue al Registro. Reinicia el equipo a continuación y comprueba si se ha solucionado.

Windows Registry Editor Version 3.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Setup]

"BootDir"="C:\\"
"SourcePath"="C:\\"
"ServicePackSourcePath"="C:\\"



Saludos
Qui dove il mare luccica e tira forte il vento

ajb1912
Usuario linuxero
Usuario linuxero
Mensajes: 11
Registrado: 07 Nov 2009, 14:12
Agradecido : 6 veces
Contactar:

Re: AYUDA CON SERVICE PACK ·

Mensajepor ajb1912 » 06 May 2012, 15:08

No ha habido suerte. Después de darle doble click al icono reparar.reg me aparece otro mensaje de error que dice: Error de registro .No se puede importar C:\Documents and Settings\AJB\Escritotio\reparar.reg:el archivo especificado no es compatible con esta versión de Windows" Yo, después de haber hecho consultas, he dado por hecho que mi versión de Windows es la 32 bits. Hubiese querido adjuntar una captura de pantalla para que tú lo vieras pero no puedo adjuntar archivos (parece ser que no lo podemos hacer todos los foreros o que no se puede haver desde este apartado del foro) .

Gracias de nuevo.

Avatar de Usuario
Souto
Usuario Bill Gates
Usuario Bill Gates
Mensajes: 10665
Registrado: 25 Feb 2008, 10:21
Ubicación: Galicia
Agradecido : 6 veces
Agradecimiento recibido: 647 veces
Contactar:

Re: AYUDA CON SERVICE PACK ·

Mensajepor Souto » 06 May 2012, 17:06

La captura la puede subir cualquier usuario. En otro momento te detallo como.
Pero para este caso, no hace falta. Lo hago yo por tí


Imagen


el archivo especificado no es compatible con esta versión de Windows


Lo lamento, el error ha sido mío. He tenido un lapsus.
Simplemente haz ratón derecho sobre reparar.reg>Editar y donde dice
Windows Registry Editor Version 3.00
cámbialo a
Windows Registry Editor Version 3.0

Archivo>guardar y vuelve a hacer doble clic sobre él.


Saludos
Qui dove il mare luccica e tira forte il vento

ericmoreiraperez
Usuario linuxero
Usuario linuxero
Mensajes: 12
Registrado: 06 May 2012, 19:51
Contactar:

Re: AYUDA CON SERVICE PACK ·

Mensajepor ericmoreiraperez » 06 May 2012, 19:59

has probado con las actualizaciones automaticas , en el caso que tengas windows xp original ?

ajb1912
Usuario linuxero
Usuario linuxero
Mensajes: 11
Registrado: 07 Nov 2009, 14:12
Agradecido : 6 veces
Contactar:

Re: AYUDA CON SERVICE PACK ·

Mensajepor ajb1912 » 06 May 2012, 20:49

ericmoreiraperez escribió:has probado con las actualizaciones automaticas , en el caso que tengas windows xp original ?


Hola Enric. Sí, mi Windows es original y, sí, he probado también las actualizaciones automáticas pero no sé por qué razón me sigue indicando que mantengo el SP2 después de las actualizaciones automáticas.

De cualquier forma me pongo a hacer lo que me indicado Souto, ya os contaré.


Volver a “Windows XP / X64”

¿Quién está conectado?

Usuarios navegando por este Foro: No hay usuarios registrados visitando el Foro y 4 invitados