Problema al hacer click en vinculos Word 2010? [Solucionado]

Foro referente al sistema operativo Windows 7
fernandobranca
Usuario linuxero
Usuario linuxero
Mensajes: 11
Registrado: 28 Jul 2010, 16:42
Contactar:

Problema al hacer click en vinculos Word 2010? [Solucionado]

Mensajepor fernandobranca » 28 Jul 2010, 16:52

Buenas soy novato aqui...queria pedir un poco de ayuda con este problema que tengo...
Resulta que al clickear en algun vinculo de direcion web, dentro de algun programa o software que no sea el explorador de internet (messenger por ejemplo) que tengo como predefinido el explorer de navegacion de windows, ocurre que me abre el word del office 2010 para resolver esta direccion...obviamente no abre la pagina completa ni tampoco es lo q quiero!...
He aqui mi drama,espero que si saben algo y me pueden ayudar a como corregir este error les estaria muy agradecido
saludos!

Avatar de Usuario
Jokerm
Usuario topetorpe
Usuario topetorpe
Mensajes: 178
Registrado: 18 May 2008, 21:43
Agradecido : 3 veces
Agradecimiento recibido: 3 veces
Contactar:

Re: Problema al hacer click en vinculos -> Microsoft Word 2010?

Mensajepor Jokerm » 29 Jul 2010, 03:58

esto se podria solucionar con asociando bien el vinculo a tu navegador.

Cuando haces clic en un link, tu computadora busca el programa marcado por defecto para abrir una direccion de hipertexto http. Podria ser que tu maquina asocie a esto con el WOrd.

Por lo que propongo asociar bien el programa internet explorer.

No conosco algun comando para lograrlo, y en windows 7 desconosco exactamente corregir las asociaciones.

Pero te propongo lo siguiente.

Descarga windows 7 manager, puedes buscarlo y bajar el modo trial. Procedes a instalarlo.

La primera vez que lo abras te saldra esta pantalla

http://i36.tinypic.com/6rsswm.jpg

Procedes a dar clic en Repair Center y te saldra esta pantalla

http://www.intowindows.com/wp-content/uploads/2009/05/repaircenter.jpg

Procedes a dar clic en "File Association"

Clic en fix. Espero resulte
Suerte
Odio la SOPA

fernandobranca
Usuario linuxero
Usuario linuxero
Mensajes: 11
Registrado: 28 Jul 2010, 16:42
Contactar:

Re: Problema al hacer click en vinculos -> Microsoft Word 2010?

Mensajepor fernandobranca » 03 Ago 2010, 15:29

Interesante ayuda compañero..pero no me funciono..
Le di fix a todos los file type y nada..me sigue abriendo el word en vez del explorador,es muy raro,no se que sucede..
Muchas Gracias de todas maneras..
Espero otra ayudita
Saludos!

Avatar de Usuario
Souto
Usuario Bill Gates
Usuario Bill Gates
Mensajes: 10665
Registrado: 25 Feb 2008, 10:21
Ubicación: Galicia
Agradecido : 6 veces
Agradecimiento recibido: 647 veces
Contactar:

Re: Problema al hacer click en vinculos -> Microsoft Word 2010?

Mensajepor Souto » 03 Ago 2010, 16:01

La propuesta de Jokerm es acertada; pero podría no haber funcionado porque para la extensión .lnk tengas algún añadido espúrero. Es fácil de comprobar
Teclas windows+r y ahí tecleas regedit
se abrirá el editor del Registro y en la ventana de la izquierda deberás ir expandiendo esta ruta
HKEY_CLASSES_ROOT\.lnk
ratón derecho sobre la clave .lnk>>Exportar y la guardas en Escritorio con cualquier nombre.
Cierra el editor del Registro y haz ratón derecho>>Editar sobre el archivo que guardaste en Escritorio. A continuación seleccionas ese texto, lo copias y lo pegas en el Foro.

Saludos
Qui dove il mare luccica e tira forte il vento

fernandobranca
Usuario linuxero
Usuario linuxero
Mensajes: 11
Registrado: 28 Jul 2010, 16:42
Contactar:

Re: Problema al hacer click en vinculos -> Microsoft Word 2010?

Mensajepor fernandobranca » 04 Ago 2010, 13:06

Bueno siguiendo un poco lo que souto me dijo me encontre que en mi HKEY_CLASSES_ROOT\.lnk existen 2 subcarpetas ---> ShellEx y ShellNew..
disculpando un poco mi mediocridad lo que hice fue tomar como clave a la "carpeta" digamos \.lnk y seguir los pasos siguientes de exportar y luego editar y por consiguiente esto salio en el editor de notas...



Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\.lnk]
@="lnkfile"

[HKEY_CLASSES_ROOT\.lnk\ShellEx]

[HKEY_CLASSES_ROOT\.lnk\ShellEx\{000214EE-0000-0000-C000-000000000046}]
@="{00021401-0000-0000-C000-000000000046}"

[HKEY_CLASSES_ROOT\.lnk\ShellEx\{000214F9-0000-0000-C000-000000000046}]
@="{00021401-0000-0000-C000-000000000046}"

[HKEY_CLASSES_ROOT\.lnk\ShellEx\{00021500-0000-0000-C000-000000000046}]
@="{00021401-0000-0000-C000-000000000046}"

[HKEY_CLASSES_ROOT\.lnk\ShellEx\{BB2E617C-0920-11d1-9A0B-00C04FC2D6C1}]
@="{00021401-0000-0000-C000-000000000046}"

[HKEY_CLASSES_ROOT\.lnk\ShellNew]
"Handler"="{ceefea1b-3e29-4ef1-b34c-fec79c4f70af}"
"IconPath"=hex(2):25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,00,6f,00,6f,00,\
74,00,25,00,5c,00,73,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,00,73,\
00,68,00,65,00,6c,00,6c,00,33,00,32,00,2e,00,64,00,6c,00,6c,00,2c,00,2d,00,\
31,00,36,00,37,00,36,00,39,00,00,00
"ItemName"="@shell32.dll,-30397"
"MenuText"="@shell32.dll,-30318"
"NullFile"=""

[HKEY_CLASSES_ROOT\.lnk\ShellNew\Config]
"DontRename"=""

La verdad que no se de que demonios estamos tratando, y me interesaria saber que estamos haciendo pues aparte de estar agradecido por la ayuda tambien espero que el foro funcione como enseñanza e intercambio de conocimientos...

Gracias Souto y a todo el que me ayuda y comentenme que estariamos haciendo!
Saludos

Avatar de Usuario
Souto
Usuario Bill Gates
Usuario Bill Gates
Mensajes: 10665
Registrado: 25 Feb 2008, 10:21
Ubicación: Galicia
Agradecido : 6 veces
Agradecimiento recibido: 647 veces
Contactar:

Re: Problema al hacer click en vinculos -> Microsoft Word 2010?

Mensajepor Souto » 04 Ago 2010, 14:18

Tienes razón en tu queja: sucede que simplemente por falta de tiempo muchas veces vamos directos al tajo y no caemos en la cuenta de que el usuario no sabe hasta qué punto es confiable lo que se le propone. En cualquier caso aquí, en este foro, siempre damos una explicación. Y cuando no se hace al principio, la hacemos cuando ya tenemos un diagnóstico.

Cuando uno hace doble clic en un documento Word, por ejemplo, en algún sitio está escrito que se abra el Word. Esa anotación está justamente en el Registro, en la clave HKEY_CLASSES_ROOT y (para este ejemplo) en la subclave .doc. Si un usuario hace doble clic sobre un Word y se abre el block de notas, revisando esa subclave detectaremos el error y podremos corregirlo.

Aquí tienes un caso parecido al tuyo:
http://social.answers.microsoft.com/For ... dbb6afd4cc

En tu caso el problema está en los hipervínculos y/o en algunos accesos directos. El cómo debe comportarse un doble clic sobre un hipervínculo está predeterminado también (como todos) en HKEY_CLASSES_ROOT pero en este caso en la subclave .lnk.
El compañero Jokerm ha dado por hecho que algo no estaba bien ahí y te ha propuesto reescribir todas las subcarpetas de HKEY_CLASSES_ROOT para que retomasen su comportamiento normal si es que algo estuviese alterado.
Sin embargo a tí los links te funcionan normalmente bien. Sólo derivan hacia Word en un contexto muy concreto: esto dificulta sobremanera el diagnóstico.

Yo, por mi parte, suelo proceder de otra manera. Te he pedido que exportes .lnk (exportar es simplemente hacer una copia sin alterar la original) para dos cosas:
a) Conocer su contenido y comprobar si es normal
b) Tener una copia de seguridad de esa clave por si luego reparando "se me va la mano" y rompo algo. Simplemente haciendo doble clic sobre la copia exportada, volveríamos a la situación de partida.

Acabo de mirar la clave que has exportado y en mi opinión , en el apartado ShellEX contiene Handlers (manejadores) que no se corresponden.

Lamentablemente no tengo ahora aquí un Windows 7. Así que si te parece esperaremos a que asome por aquí alguien con un W7 y nos suba su HKEY_CLASSES_ROOT\.lnk para comparar con el tuyo.

Una vez que has visto la extensión de los párrafos anteriores, comprenderás porqué todavía no te hemos dado una explicación ;)

Saludos
Qui dove il mare luccica e tira forte il vento

Avatar de Usuario
helheim
Usuario Bill Gates
Usuario Bill Gates
Mensajes: 5001
Registrado: 20 Abr 2008, 11:38
Agradecido : 24 veces
Agradecimiento recibido: 169 veces
Contactar:

Re: Problema al hacer click en vinculos -> Microsoft Word 2010?

Mensajepor helheim » 04 Ago 2010, 16:28

Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\.lnk]
@="lnkfile"

[HKEY_CLASSES_ROOT\.lnk\ShellEx]

[HKEY_CLASSES_ROOT\.lnk\ShellEx\{000214EE-0000-0000-C000-000000000046}]
@="{00021401-0000-0000-C000-000000000046}"

[HKEY_CLASSES_ROOT\.lnk\ShellEx\{000214F9-0000-0000-C000-000000000046}]
@="{00021401-0000-0000-C000-000000000046}"

[HKEY_CLASSES_ROOT\.lnk\ShellEx\{00021500-0000-0000-C000-000000000046}]
@="{00021401-0000-0000-C000-000000000046}"

[HKEY_CLASSES_ROOT\.lnk\ShellEx\{BB2E617C-0920-11d1-9A0B-00C04FC2D6C1}]
@="{00021401-0000-0000-C000-000000000046}"

[HKEY_CLASSES_ROOT\.lnk\ShellNew]
"Handler"="{ceefea1b-3e29-4ef1-b34c-fec79c4f70af}"
"IconPath"=hex(2):25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,00,6f,00,6f,00,\
74,00,25,00,5c,00,73,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,00,73,\
00,68,00,65,00,6c,00,6c,00,33,00,32,00,2e,00,64,00,6c,00,6c,00,2c,00,2d,00,\
31,00,36,00,37,00,36,00,39,00,00,00
"ItemName"="@shell32.dll,-30397"
"MenuText"="@shell32.dll,-30318"
"NullFile"=""

[HKEY_CLASSES_ROOT\.lnk\ShellNew\Config]
"DontRename"=""



Oído cocina.

Un saludo.
La experiencia es una llama que alumbra quemando (Benito Pérez Galdós)

Avatar de Usuario
Souto
Usuario Bill Gates
Usuario Bill Gates
Mensajes: 10665
Registrado: 25 Feb 2008, 10:21
Ubicación: Galicia
Agradecido : 6 veces
Agradecimiento recibido: 647 veces
Contactar:

Re: Problema al hacer click en vinculos -> Microsoft Word 2010?

Mensajepor Souto » 04 Ago 2010, 17:16

Oído cocina.

Así da gusto, esto es un buen equipo y lo demás...los de Redmond :lol:

Como tú mismo puedes comprobar, fernandobranca, tu Registro y el de helheim son idénticos.
Esto quiere decir que he apuntado mal y no está ahí el entuerto. :(

¿Donde está, entonces?
Sinceramente, ni idea. Quizá spyware, pero no lo sé. Tal vez una barra del navegador. ¿Qué antivirus tienes?
Podrías ponernos algún ejemplo más de la incidencia?:
¿Qué sucede si pinchas en un enlace que tienes en un documento de Word?
¿Qué sucede si pinchas en un enlace que tienes en este foro?
Por último: arranca el equipo y pulsa F8 para que se muestren los modos de inicio avanzados, posiciónate sobre "modo seguro con funciones de red" y da intro; inicia sesión y comprueba si en este modo tienes igualmente el problema.

Saludos
Qui dove il mare luccica e tira forte il vento

fernandobranca
Usuario linuxero
Usuario linuxero
Mensajes: 11
Registrado: 28 Jul 2010, 16:42
Contactar:

Re: Problema al hacer click en vinculos -> Microsoft Word 2010?

Mensajepor fernandobranca » 04 Ago 2010, 17:50

oh super!
Bueno he probado clickear archivos word y me abre correctamente el documento...
Probando clickear vinculos dentro de internet explorer (mi explorador) tambien resulta perfecto el funcionamiento --> Abre la pagina correspondiente..
El ejemplo mas claro que tengo para brindarte es el siguiente:
----->
Dentro de mi sesion de Live Messenger, se me ocurre por ejemplo clickear en el boton de bandeja de entrada para ver mi correo o ver perfil de algun contacto o lo que tenga ganas de vincular con internet y aqui que se me cae un cabello por cada vez que me abre el Word 2010...jajaj..es broma lo del cabello,deberia estar pelado!jaja..pero me fastidia mucho pues me occurre lo mismo con cualquier otro programa o soft al que le vincule con internet.
<-----
No se si me entiende bien a lo que me refiero..y no quiero llegar a tener que desinstalar el office o el explorer siendo que debe ser algo muy tonto lo que ocurre...usaba el eset nod32 cuando esto me empezo a ocurrir, cambie por el avast! busque virus o malwares, utilice Ccleaner para reparar errores, y todo perfecto..no se mas que haremos...me queda probar iniciando en modo seguro con funciones de red y despues comento que tal me fue...
Muchas gracias por colaborar y espero que logremos vencer a esta adversidad ja
Saludos!

Avatar de Usuario
helheim
Usuario Bill Gates
Usuario Bill Gates
Mensajes: 5001
Registrado: 20 Abr 2008, 11:38
Agradecido : 24 veces
Agradecimiento recibido: 169 veces
Contactar:

Re: Problema al hacer click en vinculos -> Microsoft Word 2010?

Mensajepor helheim » 04 Ago 2010, 20:40

Inténtalo de la siguiente forma:

Vete a Inicio/Programas Predeterminados/Asociar un tipo de archivo o protocolo con un programa

En la ventana que te muestra encontrarás las asociaciones de tipos de archivos.

Ordena la lista que te sale por programas (pulsando en Predeterminada), buscas Microsoft Office Word y nos dices a que extensiones y protocolos está asociadas el programa.

Es posible que el protocolo HTTP lo tengas asociado a Microsoft Office Word.

Un saludo.
La experiencia es una llama que alumbra quemando (Benito Pérez Galdós)


Volver a “Windows 7”

¿Quién está conectado?

Usuarios navegando por este Foro: Bing [Bot] y 6 invitados