No puedo arrancar Server 2003 tras instalar Windows7 Tema Solucionado

Foro referente al sistema operativo Windows 7
Avatar de Usuario
manolain
Usuario linuxero
Usuario linuxero
Mensajes: 25
Registrado: 15 May 2011, 11:50
Contactar:

No puedo arrancar Server 2003 tras instalar Windows7

Mensajepor manolain » 15 May 2011, 11:51

Hola a todos,

Hago una llamada desesperada, a ver si me pueden ayudar.

Tenía en mi máquina tres sistemas operativos: Ubuntu, Win XP y Server 2003. Arrancaba con GRUB que me daba a elegir para arrancar ubuntu, o las diferentes versiones de windows. Entrando en esta última, me daba a su vez a escoger entre Win XP o Server, todo funcionaba perfectamente.

Instalé Windows 7 sobre la partición de XP, que era la primaria (c:\). Recuperé el arranque de ubuntu con super grub, y tengo la misma situación que antes. Ahora, en el menú de arranque de windows, me ofrece windows 7 y "versión anterior de windows", pero éste no funciona, no hace nada.

He instalado EasyBCD para intentar arreglar esto, pero no he conseguido nada. He añadido nuevo arranque de Server 2003 (en modo fastdetect y especificando explícitamente la unidad D), pero nada, siempre que clico la opción de Server 2003 la pantalla se va a negro, y no hace absolutamente nada más.

Así es como ha quedado los boot settings

Código: Seleccionar todo

    There are a total of 3 entries listed in the bootloader.

    Default: Windows 7

    Timeout: 15 seconds

    Boot Drive: C:\

    Entry #1

    Name: Versi¢n anterior de Windows

    BCD ID: {ntldr}

    Drive: C:\

    Bootloader Path: \ntldr

    Entry #2

    Name: Windows 7

    BCD ID: {current}

    Drive: C:\

    Bootloader Path: \Windows\system32\winload.exe

    Entry #3

    Name: Server 2003

    BCD ID: {18fe5dc2-7e9a-11e0-b4ef-a83f19c151fa}

    Drive: D:\

    Bootloader Path: \NST\easyldr1


En la unidad D, donde está el Server, he añadido un típico fichero boot.ini como este

[boot loader]

timeout=5

default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS

[operating systems]

multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Windows Server 2003, Enterprise" /noexecute=optout /fastdetect


Pero lo único que he conseguido es que, al seleccionar server 2003 en el arranque, en vez de irse la pantalla a negro, me saque un mensaje de error tipo "el sistema no puede arrancarse por un problema de hardware/software"

Por favor, si alguien pudiera ayudarme con esto…..necesito imperiosamente arrancar el server 2003, lo utilizo para mi trabajo, y no está la cosa para andar con tonterías

Gracias!!

Avatar de Usuario
manolain
Usuario linuxero
Usuario linuxero
Mensajes: 25
Registrado: 15 May 2011, 11:50
Contactar:

Re: No puedo arrancar Server 2003 tras instalar Windows7

Mensajepor manolain » 15 May 2011, 15:04

Por si puede ayudar, aquí está mi mapa de particiones: las dos primeras son las de ubuntu (sistema y swap), luego está c (win7) y luego D (server 2003)

http://i54.tinypic.com/2q0352a.jpg


Gracias de nuevo!

Avatar de Usuario
Souto
Usuario Bill Gates
Usuario Bill Gates
Mensajes: 10665
Registrado: 25 Feb 2008, 10:21
Ubicación: Galicia
Agradecido : 6 veces
Agradecimiento recibido: 647 veces
Contactar:

Re: No puedo arrancar Server 2003 tras instalar Windows7

Mensajepor Souto » 15 May 2011, 17:09

Hola,bienvenido.

Me pierdo entre tanta vuelta pero parece claro que el GRUB está correcto y lo que contiene alguna ruta no válida es el Administrador de arranque de Windows que es quien en último extremo tiene que iniciar el Server 2003 .
Apórtanos información sobre su actual configuración ejecutanto el bcdedit.exe
windows-7-seven/entrada-de-ubuntu-residual-t11078.html?hilit=bcdedit

Lo del Boot.ini; cuando estamos en una dual, no hay que ponerlo en la partición de Server2003, sino en la partición que aloja el cargador de arranque (W7). En cualquier caso es innecesario porque seguro que está ya ahí.


En principio, la cosa no parece tener mayor dificultad.

Si nadie te atiende antes (es domingo), esta noche (me voy al monte) lo miro

Saludos
Qui dove il mare luccica e tira forte il vento

Avatar de Usuario
Souto
Usuario Bill Gates
Usuario Bill Gates
Mensajes: 10665
Registrado: 25 Feb 2008, 10:21
Ubicación: Galicia
Agradecido : 6 veces
Agradecimiento recibido: 647 veces
Contactar:

Re: No puedo arrancar Server 2003 tras instalar Windows7

Mensajepor Souto » 15 May 2011, 20:48

Bueno, ya estoy de vuelta. Aunque aún no tengo tu respuesta y puesto que el asunto te urge,
Hago una llamada desesperada, a ver si me pueden ayudar.

este es mi comentario:

La entrada que has creado de Windows Server es inválida, es un disparate. Puedes eliminarla.

Las otras dos entradas son correctas.
¿Porqué no funciona la entrada Versi¢n anterior de Windows?
Vemos lo que dice

Código: Seleccionar todo

Entry #1

    Name: Versi¢n anterior de Windows

    BCD ID: {ntldr}

    Drive: C:\

    Bootloader Path: \ntldr


El identificador de carga es NTLDR, puesto que hablamos de un Server 2003, es correcto.
La ruta del cargador también es correcta.
Drive C: también es correcto ya que aunque Windows Server está en D: el cargador, para poder ser iniciado por W7 tiene que estar en C:

¿Qué es lo que falla entonces?: probablemente que en C: no tienes NTLDR ni Boot.ini y por lo tanto las llamadas del cargador no obtienen respuesta.

Arranca con Windows 7, habilita el que se muestren los archivos ocultos y también el que no se oculten los archivos de sistema operativo. Copia el NTLDR que tienes en D: a la raiz de C:. Copia el Boot.ini que tienes en D: a la raiz de C:.

Modifica el Boot ini que has copiado a C: para que apunte a la partición donde realmente está Windows Server:
el Boot.ini que has copiado a C: dice
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Windows Server 2003, Enterprise" /noexecute=optout /fastdetect

es evidente que Windows Server no está en la partición 1. Probablemente D: será la partición 2.

Realizado todo esto reinicia el equipo y pulsando sobre la entrada Versión anterior... deberá arrrancar el Server sin ningún problema.

Cuestión aparte es que teniendo un GRUB no era necesario hacer nada de esto. Editando el GRUB puedes agregar directamente la entrada del Server y de esta manera ya no sería una subentrada de Windows 7.
Para Ubuntu se haría así:
http://www.dacostabalboa.com/es/anadir- ... ubuntu/155
Pero,en fin esto es un foro de Windows.


Saludos
Qui dove il mare luccica e tira forte il vento

Avatar de Usuario
manolain
Usuario linuxero
Usuario linuxero
Mensajes: 25
Registrado: 15 May 2011, 11:50
Contactar:

Re: No puedo arrancar Server 2003 tras instalar Windows7

Mensajepor manolain » 15 May 2011, 21:08

Hola,

Sí, si que me corría prisa, pero los hijos pequeños no entienden de estas cosas :-)

Aquí está el reporte que decías

C:\Windows\system32>bcdedit.exe

Administrador de arranque de Windows
----------------------------------
Identificador {bootmgr}
device boot
description Windows Boot Manager
locale en-US
inherit {globalsettings}
default {current}
resumeobject {1f8184a2-14de-11df-9734-f08c6d8c50b0}
displayorder {current}
{5a60f4ae-7efe-11e0-a44d-002215182db7}
toolsdisplayorder {memdiag}
timeout 10

Cargador de arranque de Windows
-----------------------------
Identificador {current}
device partition=C:
path \Windows\system32\winload.exe
description Microsoft Windows 7
locale es-ES
osdevice partition=C:
systemroot \Windows
resumeobject {a5607d6c-7efe-11e0-a5f9-806e6f6e6963}
sos No
debug No

Sector de arranque del modo real
------------------------------
Identificador {5a60f4ae-7efe-11e0-a44d-002215182db7}
device partition=D:
path \NST\easyldr2
description Server 2003
locale es-ES


Por otro lado, sobre lo que mencionas

El boot.ini que hay en c: es

Código: Seleccionar todo

; This boot.ini was automatically generated by NeoSmart Technologies' BootGrabber.exe
; Use EasyBCD from http://neosmart.net/dl.php?id=1 to manage your bootloader

[boot loader]
timeout=15
default=multi(0)disk(0)rdisk(0)partition(2)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(2)\WINDOWS="Windows XP on D:\" /fastdetect


Que ponga XP es lo de menos, debería arrancar

El NTLDR también está

De todas formas, voy a recrear la entrada tal y como dices y a probar de nuevo

Avatar de Usuario
manolain
Usuario linuxero
Usuario linuxero
Mensajes: 25
Registrado: 15 May 2011, 11:50
Contactar:

Re: No puedo arrancar Server 2003 tras instalar Windows7

Mensajepor manolain » 15 May 2011, 22:03

Nada, he seguido tus pasos, pero no hay forma de arrancar

El boot.ini de C: está como ponía antes, y la configuración de arranque es ahora

Código: Seleccionar todo

There are a total of 2 entries listed in the bootloader.

Default: Microsoft Windows 7
Timeout: 10 seconds
EasyBCD Boot Device: C:\

Entry #1
Name: Microsoft Windows 7
BCD ID: {current}
Drive: C:\
Bootloader Path: \Windows\system32\winload.exe

Entry #2
Name: Server 2003
BCD ID: {e6888172-7f00-11e0-92e2-002215182db7}
Drive: C:\
Bootloader Path: \NST\ntldr


El resultado al intentar arrancar es que la pantalla se queda en negro, sin hacer nada, y tengo que apagar a botonazo limpio

Lo malo es que el easyBCD éste se pule la información de arranque de la unidad D: (no hay ni boot.ini ni ntldr y ntdetect en dicha unidad) por lo que tampoco podría arrancarlo desde ubuntu :-(

Por cierto, muchas gracias por tu ayuda!
A ver si puedes darme alguna otra pista

Avatar de Usuario
Souto
Usuario Bill Gates
Usuario Bill Gates
Mensajes: 10665
Registrado: 25 Feb 2008, 10:21
Ubicación: Galicia
Agradecido : 6 veces
Agradecimiento recibido: 647 veces
Contactar:

Re: No puedo arrancar Server 2003 tras instalar Windows7

Mensajepor Souto » 15 May 2011, 22:50

En primer lugar, mis disculpas. He repasado mi segunda intervención y es un tanto borde :oops:
No es para nada mi estilo.
En segundo lugar, te envidio
Sí, si que me corría prisa, pero los hijos pequeños no entienden de estas cosas :-)

ya he pasado esa fase hace años y la añoro.

El bcdedit que aportas difiere bastante del estándar y buena parte de ello es por culpa del EasyBCD. A modo de ejemplo te pongo el resultado desde el equipo que ahora estoy tecleando. Es un dual Vista/XP y a los efectos sirve perfectamente ya que el administrador de arranque en Seven y Vista es igual. Si hay una diferencia en este caso, es que está predeterminado XP



Código: Seleccionar todo

C:\Windows\System32>bcdedit.exe

Administrador de arranque de Windows
----------------------------------
Identificador              {bootmgr}
device                  partition=C:
path                    \bootmgr
description             Windows Boot Manager
locale                  es-ES
inherit                 {globalsettings}
default                 {ntldr}
resumeobject            {755c66b5-6e09-11db-9b0b-e88c8501eff5}
displayorder            {755c66b4-6e09-11db-9b0b-e88c8501eff5}
                        {ntldr}
toolsdisplayorder       {memdiag}
timeout                 5
displaybootmenu         Yes

Cargador de arranque de Windows
-----------------------------
Identificador              {755c66b4-6e09-11db-9b0b-e88c8501eff5}
device                  partition=C:
path                    \Windows\system32\winload.exe
description             Microsoft Windows Vista
locale                  es-ES
inherit                 {bootloadersettings}
recoverysequence        {572bcd56-ffa7-11d9-aae0-0007e994107d}
recoveryenabled         Yes
osdevice                partition=C:
systemroot              \Windows
resumeobject            {755c66b5-6e09-11db-9b0b-e88c8501eff5}
nx                      OptIn
detecthal               No
usefirmwarepcisettings  No

Cargador del SO Windows heredado
--------------------------------------------------
Identificador              {ntldr}
device                  partition=C:
path                    \ntldr
description             Windows XP


Por su parte, el Boot.ini que hay en C:, dice

Código: Seleccionar todo

[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(3)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(3)\WINDOWS="Microsoft Windows XP Home Edition" /noexecute=optin /fastdetect

ya que el XP está en F: que es la partición 3 en este equipo.


Opciones:
1. La más razonable es añadir la entrada al GRUB. Salvo que proximamente pienses prescinir del Ubuntu, no tiene ningún sentido mantener dos administradores de arranque (el GRUB y el de W7)
http://alan-carrillo.blogspot.com/2009/ ... grub2.html

2. Olvídate del EasyBCD y crea manualmente la entrada de Windows Server en el administrador de W7
Bcdedit /create {ntldr} /d "Windows Server 2003"
Bcdedit /set {ntldr} device partition=C:
Bcdedit /set {ntldr} path \ntldr
Bcdedit /displayorder {ntldr} /addlast


http://support.microsoft.com/kb/919529/es



Saludos
Qui dove il mare luccica e tira forte il vento

Avatar de Usuario
manolain
Usuario linuxero
Usuario linuxero
Mensajes: 25
Registrado: 15 May 2011, 11:50
Contactar:

Re: No puedo arrancar Server 2003 tras instalar Windows7

Mensajepor manolain » 15 May 2011, 23:01

Disculpas más que aceptadas, aunque tampoco me sentí ofendido en ningún momento :-)

Tú añoras a los niños porculeros, yo envidio a los que tienen niños de seis años parriba, supongo que a todos nos pasa lo mismo no? jajaja

Yendo al tema

1. La más razonable es añadir la entrada al GRUB. Salvo que proximamente pienses prescinir del Ubuntu, no tiene ningún sentido mantener dos administradores de arranque (el GRUB y el de W7)

Haría todo desde el GRUB de ubuntu, pero mi duda es....¿podrá arrancar el server 2003 después de que el easybcd se haya pulido su boot.ini y demás?
Me da toda la impresión de que no será así no?

Además, cuando instalé ubuntu en su momento, éste me dejó una entrada para arrancar windows, y desde ahí, arrancar todos los windows que hubiera. Me resulta extraño que en la instalación de ubuntu éste no se hubiera encargado de todo :-(

Voy a probar de todas formas la segunda opción (borraré antes vía easybcd la entrada de server 2003) a ver qué hace, que es más rápido, y comento cómo ha ido

Avatar de Usuario
manolain
Usuario linuxero
Usuario linuxero
Mensajes: 25
Registrado: 15 May 2011, 11:50
Contactar:

Re: No puedo arrancar Server 2003 tras instalar Windows7

Mensajepor manolain » 15 May 2011, 23:11

manolain escribió:Voy a probar de todas formas la segunda opción (borraré antes vía easybcd la entrada de server 2003) a ver qué hace, que es más rápido, y comento cómo ha ido

Pos nada, no hay forma. Definitivamente, el sistema server 2003 de la unidad D está jodido, porque tampoco arranca

Ahora, el reporte de bcdedit es prácticamente igual que el tuyo (aunque mi arranque primario está en idioma en-US, no se porqué):

Código: Seleccionar todo

Microsoft Windows [Versión 6.1.7601]
Copyright (c) 2009 Microsoft Corporation. Reservados todos los derechos.

C:\Windows\system32>bcdedit

Administrador de arranque de Windows
----------------------------------
Identificador           {bootmgr}
device                  boot
description             Windows Boot Manager
locale                  en-US
inherit                 {globalsettings}
default                 {current}
resumeobject            {1f8184a2-14de-11df-9734-f08c6d8c50b0}
displayorder            {current}
                        {ntldr}
toolsdisplayorder       {memdiag}
timeout                 10

Cargador de arranque de Windows
-----------------------------
Identificador           {current}
device                  partition=C:
path                    \Windows\system32\winload.exe
description             Microsoft Windows 7
locale                  es-ES
osdevice                partition=C:
systemroot              \Windows
resumeobject            {a5607d6c-7efe-11e0-a5f9-806e6f6e6963}
sos                     No
debug                   No

Cargador del SO Windows heredado
--------------------------------------------------
Identificador           {ntldr}
device                  partition=C:
path                    \ntldr
description             Windows Server 2003


Y lo mismo: la pantalla se queda en negro, y ahí no arranca nada.

Probaré a meterlo desde grub, pero me da la impresión de que pasará lo mismo

¿Alguna utilidad o forma para recuperar el arranque de una unidad?

Gracias otra vez!!!

Avatar de Usuario
Souto
Usuario Bill Gates
Usuario Bill Gates
Mensajes: 10665
Registrado: 25 Feb 2008, 10:21
Ubicación: Galicia
Agradecido : 6 veces
Agradecimiento recibido: 647 veces
Contactar:

Re: No puedo arrancar Server 2003 tras instalar Windows7

Mensajepor Souto » 15 May 2011, 23:22

Tengo que acostarme, mañana madrugo. A primera hora te lo reviso; pero aquí hay algo más

resumeobject {1f8184a2-14de-11df-9734-f08c6d8c50b0}
resumeobject {a5607d6c-7efe-11e0-a5f9-806e6f6e6963}

hay dos identificadores de clase(GUID) diferentes para único objeto.

Explica los pasos que has dado tras instalar W7. En concreto: cómo reparaste el GRUB.


Saludos
Qui dove il mare luccica e tira forte il vento


Volver a “Windows 7”

¿Quién está conectado?

Usuarios navegando por este Foro: Yahoo [Bot] y 8 invitados