Bootmgr is missing Tema Solucionado

Foro referente al sistema operativo Windows 7
csrfrz
Usuario linuxero
Usuario linuxero
Mensajes: 2
Registrado: 25 Ago 2010, 22:56
Contactar:

Bootmgr is missing

Mensajepor csrfrz » 25 Ago 2010, 23:16

Tengo un portatil dell, vienen 3 particiones, una en fat16 de 32 mb que se llama dell utilities, otra Ntfs de 14 Gb Recovery (boot primary) donde venia el backup de fabrica, y la ntfs del win 7 de 450 gb (primary). Que ha pasado? Pues que formatee la particion recovery (la renombre recuperacion) porque queria guardar ahi una nueva backup con el acronis y la particion donde tenia el win 7 la quise dividir en 2 para guardar ahi las fotillos y esas cosas (esta aparece ahora como sin formato y de tamaño 1 mb, cuando le puse 50 Gb, no la puedo tocar con gparted), me pide reiniciar y cuando reinicié me salia la pantalla con el logo de dell como siempre (f2 setup, f12 boot options) y luego ntldr is missing, entonces me acorde que no habia puesto a la particion del win 7 como bootable, baje un live cd con gparted y la puse, entonces me sigue saliendo lo de dell y es cuando me salió el bootmgr is missing. Lo de reparar con el cd de win 7 esta probado.

Cosas que he probado leyendo por ahi y por aqui:
1-
bootrec /fixmbr
bootrec /fixboot
bootrec /rebuildbcd

No funciona, no reconocia ningun windows

2-
diskpart >> list disk >> select disk X >> list partition >> detail partition y sino lo estuviera:

select partition X >> active

Ya la tenia activa.

3- Sacado de aqui -> mensaje-bootmgr-is-missing-t3572.html Probe los metodos de: http://support.microsoft.com/kb/927391/es

Con el metodo 2 creí que lo habia solucionado pq me preguntaba si queria añadir c:\windows y le di que si, pero nada.

Con el metodo 3 el problema es que no me aparece el guid del resumeobject por ningun lado, en displayorder pone default y en default tambien pone default, lo demas esta en orden creo, device partition c: y demas cosillas que vienen

He pensado en borrar las otras dos particiones con el gparted y quedarme solo con la del win 7 y probar a reparar otra vez, funcionara?¿
Gracias de antemano :)

Avatar de Usuario
Souto
Usuario Bill Gates
Usuario Bill Gates
Mensajes: 10665
Registrado: 25 Feb 2008, 10:21
Ubicación: Galicia
Agradecido : 6 veces
Agradecimiento recibido: 647 veces
Contactar:

Re: Bootmgr is missing

Mensajepor Souto » 26 Ago 2010, 08:29

Hola, bienvenido.
En realidad lo que has hecho es un auténtico destrozo de la tabla de particiones. Da igual qué método utilices (Bootrec, Diskpart, clonado de boot...). Es absurdo intentar recomponer algo que está mal construido desde la base.
Por otra parte es lamentable que te hayas cargado tanto la posibilidad de lanzar la partición de rescate, como así mismo la propia partición en sí.

Pero, en fin, tú mandas :? .

Mi consejo:

Arranca con el dvd de instalación, en la ventna que te muestra las particiones elimínalas todas (es obvio que lo perderás todo) y haz una instalación limpia de W7 es un disco sin particionar. Con esto, además del sistema operativo, se generará una pequeña partición que será la responsable de lanzar el arranque.

Una vez instalado el S.O., el propio admistrador de discos de W7 es una herramienta más que sobrada y suficiente para redimensionar las particiones en las dimensiones que te interese.

Por último, yo crería una imagen del sistema (desde el propio W7, sin necesidad de herramientas ajenas) e implementaría las copias de seguridad. Aquí tienes un magnífico tutorial al respecto tanto para una cosa, como para la otra
restaurar-windows-7-a-partir-de-una-imagen-de-sistema-t9212.html

No compensa en tiempo ni en esfuerzo investigar el estado lógico de ese disco y reparar la tabla de particiones.


Saludos
Qui dove il mare luccica e tira forte il vento

csrfrz
Usuario linuxero
Usuario linuxero
Mensajes: 2
Registrado: 25 Ago 2010, 22:56
Contactar:

Re: Bootmgr is missing

Mensajepor csrfrz » 26 Ago 2010, 12:58

Solucionado :D
Bueno pues al final se salvó la cosa hombre, no fue tanto el destrozo.
Como ya dije creia que el metodo 2 habia funcionado, y asi fue, lo unico que tenia que volver a arrancar con el cd de w7 y volver a reparar el inicio, eso es lo que me faltó hacer.
Por suerte no he tenido que perder nada, eso si, te hare caso y utilizare las herramientas del propio w7, gracias y un saludo.

Avatar de Usuario
helheim
Usuario Bill Gates
Usuario Bill Gates
Mensajes: 5001
Registrado: 20 Abr 2008, 11:38
Agradecido : 24 veces
Agradecimiento recibido: 169 veces
Contactar:

Re: Bootmgr is missing

Mensajepor helheim » 26 Ago 2010, 13:33

csrfrz escribió:Bueno pues al final se salvó la cosa hombre, no fue tanto el destrozo.
El destrozo está más en el hecho de haberte cargado la Partición de Rescate (por lo tanto ese destrozo sigue existiendo). Esa partición no se debe tocar nunca. 14 GB no suponen mucho espacio teniendo en cuenta la capacidad de tu disco duro (450 GB).

Con que hubieses redimensionado la partición donde tienes instalado Windows 7 y creado una nueva partición en el nuevo espacio No asignado, hubiese sido más que suficiente. Luego en esa nueva partición para datos, creas una carpeta donde guardas esa clonación manual (de Windows 7) que querías tener y listo.

Un saludo.
La experiencia es una llama que alumbra quemando (Benito Pérez Galdós)

fantafree
Usuario linuxero
Usuario linuxero
Mensajes: 26
Registrado: 28 Ene 2012, 20:27
Agradecido : 5 veces
Contactar:

Re: Bootmgr is missing

Mensajepor fantafree » 28 Ene 2012, 20:37

Buenas, antes de nada saludos al foro,

Me encuentro en la misma situación, pero sin haber borrado nada, he probado todo lo que he visto por ahí, pero sin solución....

Paso a explicar que pasos he seguido, por si alguien me puede orientar.

-El problema creo que viene por unas particiones mal hechas intentando instalar linux en otra particion y modificar el mbr.
Aclarar que ejecuté una herramienta de Linux para clonar la MAC del bluetooth de mi iphone y pasarle la agenda al bluetooth del coche. Se me ocurrió instalarlo en el disco duro desde el propio livecd y de aquí todos los problemas...

Pensaba que tenbia un disco duro ssd de 512 gigas, que estaba particionado en 4 de 128gb ( es lo que parecía marcar linux) pero deben ser 4 unidos entre si, por lo que es posible que instalara el arranque nuevo y la distribuciin linux todo en el mismo disco donde esta el W7 ultimate 64 bits, aunque en Linux me lo siguen montando como particiones diferentes:

/dev/sda
----/sda1
----/sda2
----/sda3
/dev/sdb
----/sdb1
----/sdb2
----/sdb3
/dev/sdc
/dev/sdd

-Tengo acceso a los datos de las particiones del disco, con livecds, tanto con el northon gost, como con livecd de linux, o un disco con w7 o hiren`s boot.
-El SO que tengo ( creo que todavia esta instalado) es W7 64 bits ultimate.
-He probado ya soluciones de reparar desde el dvd de w7, por linea de comandos:

bootrec /fixmbr
bootrec /fixboot
bootrec /rebuildbcd

Instalaciones de windows examinadas correctamente.
Total de instalaciones de windows identificadas: 0
La operacion se completo correctamente.


Pero sin resultado. El caso es que en ningun caso encuentra el SO.

Tengo tres particiones, que ya venian de origen: ( En diskpart: list partition de disk 0)

Num particion tipo tamaño Desplazamiento

-Particion1 Principal 16gb 1024 kb
-Particion2 Principal 100mb 16gb
-Particion3 Principal 460gb 16gb


No se muy bien que hacer ya, o sea no se identificar el problema, si es que windows ya no existe, o falta el /boot
o el mbr corrupto...

Si alguien me puede orientar genial.. Ya que yo creo que Windows está en la particion mas grande, pero ya no estoy seguro de nada..

He pasao tambien el testdisk, pero no sé exactamente lo que busco...

Cuando arranco con livecd de w7, el del northon gost, aparece otra unidad de disco llamada boot ( X)..

No sé si la habré creado yo con mis pruebas desde linux.. o no sé...

Me fastidiaria reinstalar w7, y tener que perder la configuracion de fabrica del Vaio....

Si habéis leido hasta aqui, gracias.

Avatar de Usuario
Souto
Usuario Bill Gates
Usuario Bill Gates
Mensajes: 10665
Registrado: 25 Feb 2008, 10:21
Ubicación: Galicia
Agradecido : 6 veces
Agradecimiento recibido: 647 veces
Contactar:

Re: Bootmgr is missing

Mensajepor Souto » 28 Ene 2012, 21:08

Hola, bienvenido
bootrec /rebuildbcd

Instalaciones de windows examinadas correctamente.
Total de instalaciones de windows identificadas: 0
La operacion se completo correctamente.


Si hay un almacén de arranque (BCD) dañado ó inaccesible, siempre obtendrás esa respuesta, aunque no se corresponda con la realidad.

Prueba a hacerlo así:
Arranca con el DVD, vete a línea de comandos, cambia a la unidad C: y haz un dir. Comprueba si hay un directorio Boot. Si es así, procede de esta manera:

bcdedit /export C:\BCD_Backup
c:
cd boot
attrib bcd -s -h -r
ren c:\boot\bcd bcd.old
bootrec /RebuildBcd

He pasao tambien el testdisk, pero no sé exactamente lo que busco...

El Testdisk no corre bien en arquitecturas x64




Saludos
Qui dove il mare luccica e tira forte il vento

fantafree
Usuario linuxero
Usuario linuxero
Mensajes: 26
Registrado: 28 Ene 2012, 20:27
Agradecido : 5 veces
Contactar:

Re: Bootmgr is missing

Mensajepor fantafree » 28 Ene 2012, 21:22

Gracias por la respuesta.

No hay directorio boot en C.

Tengo los tipicos:
Archivos de programa
Windows
Users
.......

Avatar de Usuario
Souto
Usuario Bill Gates
Usuario Bill Gates
Mensajes: 10665
Registrado: 25 Feb 2008, 10:21
Ubicación: Galicia
Agradecido : 6 veces
Agradecimiento recibido: 647 veces
Contactar:

Re: Bootmgr is missing

Mensajepor Souto » 28 Ene 2012, 21:48

fantafree escribió:Gracias por la respuesta.

No hay directorio boot en C.

Tengo los tipicos:
Archivos de programa
Windows
Users
.......



No es posible que haya desaparecido; pero sí lo es que esté en otra unidad.
Según en que forma haya sido instalado Seven (con disco preparticionado ó no) la carpeta Boot podría estar en esa partición de 100MB. desde el DVD de Seven nopodrás explorarla porque seguramente no tiene volumen asociado. Arranca con un live de Linux (Ubuntu x64, por ejemplo) y comprueba si es así.


Saludos
Qui dove il mare luccica e tira forte il vento

fantafree
Usuario linuxero
Usuario linuxero
Mensajes: 26
Registrado: 28 Ene 2012, 20:27
Agradecido : 5 veces
Contactar:

Re: Bootmgr is missing

Mensajepor fantafree » 28 Ene 2012, 22:58

Llevo un buen rato intentando explorarlo con un livecd, pero no doy con el comando apropiado para ver si si esa aprticion lleva /boot dentro..

he sacado un listado de las que hay con fdisk -l
info de esa partición con hdparm -1 /dev/sda2

Pero no se como hacerle un ls, ya que no es un directorio...

Avatar de Usuario
Souto
Usuario Bill Gates
Usuario Bill Gates
Mensajes: 10665
Registrado: 25 Feb 2008, 10:21
Ubicación: Galicia
Agradecido : 6 veces
Agradecimiento recibido: 647 veces
Contactar:

Re: Bootmgr is missing

Mensajepor Souto » 28 Ene 2012, 23:28

Creí que te resultaría más cómodo desde un live-cd de UBUNTU; pero, en fin, no te preocupes, casi todo tiene solución

-Particion1 Principal 16gb 1024 kb
-Particion2 Principal 100mb 16gb
-Particion3 Principal 460gb 16gb

Los equipos con una partición de 100MB son aquellos en los cuales Windos 7 se instaló sobre espacio no particionado, es decir, se dejó que fuese el propio sistema el que asignase el particionado. Este parecería ser tu caso; pero tratándose de un DELL, salvo que tuviese otro sistema originalmente y se cambiase a Seven, no es normal la existencia de esa partición. Ya que DELL utiliza el el kit de instalación automatizada de Windows (Windows AIK)

Intenta obtener más información: arranca con el DVD de Seven, vete a línea de comandos y teclea:
diskpart
sel disc 0 (es un cero)
list part
sel part X (donde X debes sustiturlo por el numero que corresponda a la de 100MB)
detail part

La información que debería dar sobre los detalles de la de 100MB sería:
Particion: X
Tipo: 07
Oculta: No
Activa: SI

1.¿qué es lo que dice en tu caso?
2. Tu equipo lleva en la trasera una etiqueta en la cual indica, entre otras cosas el identificador de servicio (TAG). ¿Qué dice en TAG?

Saludos
Qui dove il mare luccica e tira forte il vento


Volver a “Windows 7”

¿Quién está conectado?

Usuarios navegando por este Foro: Bing [Bot], Exabot [Bot] y 1 invitado