Problema al instalar un programa en windows 10

Foro referente al sistema operativo Windows 10
tarruxe
Usuario linuxero
Usuario linuxero
Mensajes: 16
Registrado: 16 Sep 2016, 10:51
Contactar:

Problema al instalar un programa en windows 10

Mensajepor tarruxe » 17 Oct 2016, 10:41

Buenos días a tod@s!!!

Os planteo mi problema a ver si me podéis echar un cable.
El caso es que este problema se ha planteado al instalar este programa en windows 10, ya que en windows 7 me funcionaba a la perfección. Se trata de un programa de entrenamiento sobre lectura rápida de Ramón Campayo.... http://www.ramoncampayo.com/

Por si acaso queréis hacer la prueba he encontrado un link que parece que te permite descargarte el programa....

http://comotriunfarenla-vida.blogspot.com.es/2013/08/curso-definitivo-de-lectura-rapida.html

Bueno....., pues a lo que voy.....

La instalación del programa la hice en modo compatibilidad con windows 7, ya que sino no me dejaba instalarlo. Lo instalé y luego ejecuté el parche de compatiblidad del TSR 1.2 que proporciona Ramón Campayo en su web. Hasta aquí todo sin problemas. En caso es que cuando ya está el programa instalado y lo ejecuto, me da el siguiente error a la hora de crear el usuario...., (os voy a poner todo el detalle del error en varias capturas ya que el espacio que da la ventana para mostrar la información sobre el error es bien escaso como veréis)

Imagen

Imagen

Imagen

Imagen

Imagen

Imagen

Imagen

Imagen

Imagen

Imagen

Imagen

Imagen

Imagen

Para ampliaros algo más la información os diré que tratando de solucionar el problema y leyendo por internet he instalado lo siguiente:

Microsoft Access Database Engine 2010 Redistributable
https://www.microsoft.com/en-us/download/details.aspx?id=13255

Microsoft .NET Framework 3.5 Service Pack 1
https://www.microsoft.com/es-ES/download/details.aspx?id=22

Además os diré que si pulsas el botón CONTINUAR que muestra la ventana del error, te permite acceder al programa e incluso crearte un usuario. Pero el problema real viene cuando empiezas a entrenar que no te guarda el resultado del test inicial que debes hacer para empezar con el entrenamiento.

El fallo una vez creado el usuario, como os he comentado en el párrafo anterior, me sigue dando concretamente cuando pulso el botón SELECCIONAR tal cual véis en la imagen que os pongo abajo....

Imagen

El caso es que este programa lo utilizo mucho ya que quiero mejorar mi velocidad de lectura y al cambiar a windows 10 me he encontrado con todo este problema.

Agradecería mucho vuestra ayuda y vuestro tiempo.
Un saludo.

Avatar de Usuario
pako
Usuario Bill Gates
Usuario Bill Gates
Mensajes: 3602
Registrado: 22 Ene 2008, 13:30
Ubicación: España
Agradecido : 50 veces
Agradecimiento recibido: 277 veces
Contactar:

Re: Problema al instalar un programa en windows 10

Mensajepor pako » 17 Oct 2016, 15:41

Hola,

Acabo de mirar los requisitos de Turbo-Speed Reader:

Windows XP SP2 o superior
.NET Framework 3.5 (en caso de no estar instalado se descargará de Internet)


Es normal que un programa para XP no te vaya en Windows 10. Lo primero es que si es para Windows XP, deberías de poner en el modo de compatibilidad para XP y no para Windows 7.

Aquí te dejo un video donde te dice cómo hacerlo para que te funcione, no lo he probado, pero los comentarios de la gente dicen que les funciono tanto en Windows 8.1 como en Windows 10.

https://www.youtube.com/watch?v=TzJpBlq0oXA

Suerte!

Saludos
Si has encontrado aquí la ayuda que esperabas (o incluso si no ha sido así ;) ), ayúdanos a mantener el foro con un pequeño donativo.
¡Muchas gracias!

tarruxe
Usuario linuxero
Usuario linuxero
Mensajes: 16
Registrado: 16 Sep 2016, 10:51
Contactar:

Re: Problema al instalar un programa en windows 10

Mensajepor tarruxe » 19 Oct 2016, 08:54

pako escribió:Hola,

Acabo de mirar los requisitos de Turbo-Speed Reader:

Windows XP SP2 o superior
.NET Framework 3.5 (en caso de no estar instalado se descargará de Internet)


Es normal que un programa para XP no te vaya en Windows 10. Lo primero es que si es para Windows XP, deberías de poner en el modo de compatibilidad para XP y no para Windows 7.

Aquí te dejo un video donde te dice cómo hacerlo para que te funcione, no lo he probado, pero los comentarios de la gente dicen que les funciono tanto en Windows 8.1 como en Windows 10.

https://www.youtube.com/watch?v=TzJpBlq0oXA

Suerte!

Saludos


Hola Pako!!!

Muchas gracias por tu respuesta.

He echado un vistazo a lo que me comentas y visto el vídeo que me has pasado. He realizado todos los pasos y no se me ha solucionado el problema.

Los pasos que he realizado son los siguientes:

1. Debido a que tenía instalado el Turbo-Speed Reader, lo desinstalé.

2. Acto seguido lo instalé en modo compatibilidad con WINDOWS XP SERVICE PACK 3. Eso sí, ejecutando la instalación como Administrador. Al terminar la instalación me muestra el siguiente error....

Imagen

El detalle completo de este error es el siguiente:


Consulte el final de este mensaje para obtener más detalles sobre cómo invocar a la depuración
Just-In-Time (JIT) en lugar de a este cuadro de diálogo.

************** Texto de la excepción **************
System.InvalidOperationException: El proveedor 'Microsoft.Jet.OLEDB.4.0' no está registrado en el equipo local.
en System.Data.OleDb.OleDbServicesWrapper.GetDataSource(OleDbConnectionString constr, DataSourceWrapper& datasrcWrapper)
en System.Data.OleDb.OleDbConnectionInternal..ctor(OleDbConnectionString constr, OleDbConnection connection)
en System.Data.OleDb.OleDbConnectionFactory.CreateConnection(DbConnectionOptions options, Object poolGroupProviderInfo, DbConnectionPool pool, DbConnection owningObject)
en System.Data.ProviderBase.DbConnectionFactory.CreateNonPooledConnection(DbConnection owningConnection, DbConnectionPoolGroup poolGroup)
en System.Data.ProviderBase.DbConnectionFactory.GetConnection(DbConnection owningConnection)
en System.Data.ProviderBase.DbConnectionClosed.OpenConnection(DbConnection outerConnection, DbConnectionFactory connectionFactory)
en System.Data.OleDb.OleDbConnection.Open()
en System.Data.Common.DbDataAdapter.QuietOpen(IDbConnection connection, ConnectionState& originalState)
en System.Data.Common.DbDataAdapter.FillInternal(DataSet dataset, DataTable[] datatables, Int32 startRecord, Int32 maxRecords, String srcTable, IDbCommand command, CommandBehavior behavior)
en System.Data.Common.DbDataAdapter.Fill(DataTable[] dataTables, Int32 startRecord, Int32 maxRecords, IDbCommand command, CommandBehavior behavior)
en System.Data.Common.DbDataAdapter.Fill(DataTable dataTable)
en Entrenador_de_lectura_rápida.EntrenadorLRDataSetTableAdapters.UsuariosTableAdapter.GetData()
en Entrenador_de_lectura_rápida.Users.Elección_Usuario.Elección_Usuario_Load(Object sender, EventArgs e)
en System.Windows.Forms.Form.OnLoad(EventArgs e)
en System.Windows.Forms.Control.CreateControl(Boolean fIgnoreVisible)
en System.Windows.Forms.Control.CreateControl()
en System.Windows.Forms.Control.WmShowWindow(Message& m)
en System.Windows.Forms.Control.WndProc(Message& m)
en System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
en System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)


************** Ensamblados cargados **************
mscorlib
Versión del ensamblado: 2.0.0.0
Versión Win32: 2.0.50727.8745 (WinRel.050727-8700)
Código base: file:///C:/Windows/Microsoft.NET/Framework64/v2.0.50727/mscorlib.dll
----------------------------------------
Turbo-Speed Reader
Versión del ensamblado: 1.0.0.0
Versión Win32: 1.0.0.0
Código base: file:///C:/Program%20Files%20(x86)/Ram%F3n%20Campayo/Turbo-Speed%20Reader/Turbo-Speed%20Reader.exe
----------------------------------------
System.Windows.Forms
Versión del ensamblado: 2.0.0.0
Versión Win32: 2.0.50727.8745 (WinRel.050727-8700)
Código base: file:///C:/Windows/assembly/GAC_MSIL/System.Windows.Forms/2.0.0.0__b77a5c561934e089/System.Windows.Forms.dll
----------------------------------------
System
Versión del ensamblado: 2.0.0.0
Versión Win32: 2.0.50727.8745 (WinRel.050727-8700)
Código base: file:///C:/Windows/assembly/GAC_MSIL/System/2.0.0.0__b77a5c561934e089/System.dll
----------------------------------------
System.Drawing
Versión del ensamblado: 2.0.0.0
Versión Win32: 2.0.50727.8745 (WinRel.050727-8700)
Código base: file:///C:/Windows/assembly/GAC_MSIL/System.Drawing/2.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll
----------------------------------------
System.Data
Versión del ensamblado: 2.0.0.0
Versión Win32: 2.0.50727.8745 (WinRel.050727-8700)
Código base: file:///C:/Windows/assembly/GAC_64/System.Data/2.0.0.0__b77a5c561934e089/System.Data.dll
----------------------------------------
System.Xml
Versión del ensamblado: 2.0.0.0
Versión Win32: 2.0.50727.8745 (WinRel.050727-8700)
Código base: file:///C:/Windows/assembly/GAC_MSIL/System.Xml/2.0.0.0__b77a5c561934e089/System.Xml.dll
----------------------------------------
System.Data.DataSetExtensions
Versión del ensamblado: 3.5.0.0
Versión Win32: 3.5.30729.8763 built by: WinRel
Código base: file:///C:/Windows/assembly/GAC_MSIL/System.Data.DataSetExtensions/3.5.0.0__b77a5c561934e089/System.Data.DataSetExtensions.dll
----------------------------------------
System.Configuration
Versión del ensamblado: 2.0.0.0
Versión Win32: 2.0.50727.8745 (WinRel.050727-8700)
Código base: file:///C:/Windows/assembly/GAC_MSIL/System.Configuration/2.0.0.0__b03f5f7f11d50a3a/System.Configuration.dll
----------------------------------------
mscorlib.resources
Versión del ensamblado: 2.0.0.0
Versión Win32: 2.0.50727.8745 (WinRel.050727-8700)
Código base: file:///C:/Windows/Microsoft.NET/Framework64/v2.0.50727/mscorlib.dll
----------------------------------------
System.Transactions
Versión del ensamblado: 2.0.0.0
Versión Win32: 2.0.50727.8745 (WinRel.050727-8700)
Código base: file:///C:/Windows/assembly/GAC_64/System.Transactions/2.0.0.0__b77a5c561934e089/System.Transactions.dll
----------------------------------------
System.Data.resources
Versión del ensamblado: 2.0.0.0
Versión Win32: 2.0.50727.8745 (WinRel.050727-8700)
Código base: file:///C:/Windows/assembly/GAC_MSIL/System.Data.resources/2.0.0.0_es_b77a5c561934e089/System.Data.resources.dll
----------------------------------------
System.Windows.Forms.resources
Versión del ensamblado: 2.0.0.0
Versión Win32: 2.0.50727.8745 (WinRel.050727-8700)
Código base: file:///C:/Windows/assembly/GAC_MSIL/System.Windows.Forms.resources/2.0.0.0_es_b77a5c561934e089/System.Windows.Forms.resources.dll
----------------------------------------

************** Depuración JIT **************
Para habilitar la depuración Just In Time (JIT), el archivo de configuración de esta
aplicación o equipo (machine.config) debe tener el
valor jitDebugging establecido en la sección system.windows.forms.
La aplicación también se debe compilar con la depuración
habilitada

Por ejemplo:

<configuration>
<system.windows.forms jitDebugging="true" />
</configuration>

Cuando esté habilitada la depuración JIT, cualquier excepción no controlada
se enviará al depurador JIT registrado en el equipo
en lugar de controlarlo mediante el cuadro de diálogo.




3. Cierro el cuadro de dialogo del error anterior e instalo el .NET Framework 3.5 desde el siguiente enlace....

https://www.microsoft.com/es-ES/download/details.aspx?id=22

4. Una vez instalado el .NET Framework 3.5, hago click con el botón derecho del ratón en el acceso directo al Turbo-Speed Reader que tengo en el escritorio y hago click en la opción SOLUCIONAR PROBLEMAS DE COMPATIBILIDAD. Tras esto se ejecuta un asistente que muestra durante un segundo el mensaje "DETECTANDO PROBLEMAS". Al finalizar la detección de problemas salen dos opciones, pulso en "PROBAR CONFIGURACIÓN RECOMENDADA". Tras ejecutar esto pruebo el programa y me sigue dando problemas al crear el usuario.

5. Instalo el Microsoft Access Database Engine 2010 Redistributable descargándomelo desde el siguiente enlace....

https://www.microsoft.com/en-us/download/details.aspx?id=13255

6. Luego ejecuto el parche que viene con el Turbo-Speed Reader, el cual se encuentra en la página web de Ramón Campayo... http://www.ramoncampayo.com/ , siendo el nombre de este parche .... "Actualización a TSR1.2".

7. Tras ejecutar el parche que comento en el punto 6, ejecuto el programa y al ir a crear un nuevo usuario....

Imagen

me sale el siguiente mensaje...

Imagen



Según entiendo yo, da error a la hora de escribir en la base de datos el nuevo usuario. Base de datos que por lo visto está realizada utilizando Access. Decir además que yo tengo instalado en mi portátil el Office 2016.

Espero que con toda la información que facilito sobre los pasos que he realizado sea útil para que me podáis echar una mano a solucionar esto y que pueda seguir utilizando por fin este programa.

Muchas gracias por vuestro tiempo.
Un saludo.

tarruxe
Usuario linuxero
Usuario linuxero
Mensajes: 16
Registrado: 16 Sep 2016, 10:51
Contactar:

Re: Problema al instalar un programa en windows 10

Mensajepor tarruxe » 19 Oct 2016, 09:01

Un detalle más sobre los pasos que he dado.....

Cuando instalo el .NET Framework 3.5 desde el siguiente enlace.... (ejecutándolo como administrador)

https://www.microsoft.com/es-ES/downloa ... aspx?id=22

... no hace nada. No se lanza ningún instalador ni nada de nada. Entiendo con esto que evidentemente el windows 10 tiene una versión del .Net Framework superior a la 3.5.

Avatar de Usuario
pako
Usuario Bill Gates
Usuario Bill Gates
Mensajes: 3602
Registrado: 22 Ene 2008, 13:30
Ubicación: España
Agradecido : 50 veces
Agradecimiento recibido: 277 veces
Contactar:

Re: Problema al instalar un programa en windows 10

Mensajepor pako » 19 Oct 2016, 16:35

Hola,

En versiones anteriores de Windows el .NET creo recordar que las distintas versiones salían en agregar o quitar programas, en Windows 10 vete a:

Botón derecho del ratón sobre el botón de inicio de Windows y seleccionas "programas y características".
En la parte izquierda pulsa en "Activar o desactivar las características de Windows".
En la primera opción veras ".NET Framework 3.5"

Se supone que si está instalado debería de aparecerte marcado el 3.5, más abajo veras el 4.6 pero no es necesario.

En cuanto al error del OLEDB.4.0 que luego da error al guardar en la base de datos, opino como tú y debe ser por culpa del:
Microsoft Access Database Engine 2010 Redistributable

Veo que en su interior tiene la versión de 32bits y la de 64bits, prueba a instalar los dos como administrador.

Saludos
Si has encontrado aquí la ayuda que esperabas (o incluso si no ha sido así ;) ), ayúdanos a mantener el foro con un pequeño donativo.
¡Muchas gracias!

tarruxe
Usuario linuxero
Usuario linuxero
Mensajes: 16
Registrado: 16 Sep 2016, 10:51
Contactar:

Re: Problema al instalar un programa en windows 10

Mensajepor tarruxe » 20 Oct 2016, 06:59

pako escribió:Hola,

En versiones anteriores de Windows el .NET creo recordar que las distintas versiones salían en agregar o quitar programas, en Windows 10 vete a:

Botón derecho del ratón sobre el botón de inicio de Windows y seleccionas "programas y características".
En la parte izquierda pulsa en "Activar o desactivar las características de Windows".
En la primera opción veras ".NET Framework 3.5"

Se supone que si está instalado debería de aparecerte marcado el 3.5, más abajo veras el 4.6 pero no es necesario.

En cuanto al error del OLEDB.4.0 que luego da error al guardar en la base de datos, opino como tú y debe ser por culpa del:
Microsoft Access Database Engine 2010 Redistributable

Veo que en su interior tiene la versión de 32bits y la de 64bits, prueba a instalar los dos como administrador.

Saludos


Buenos días Pako!!!

En primer lugar gracias por tu ayuda.

En cuanto a lo que me comentas...., decirte que he comprobado si la versión de .NET Framework 3.5 está instalada y sí que está instalada. Además la versión 4.5 también lo está.

En relación con el error del OLEDB.4.0 ...., me he descargado la versión de 32 bits de "Microsoft Access Database Engine 2010 Redistributable" y no me permite instalarla. Me sale el siguiente error:

Imagen

Espero que queden más opciones por probar, o alguna forma para hacer que el programa funcione...
Gracias de nuevo por toda tu ayuda.
Un saludo.

tarruxe
Usuario linuxero
Usuario linuxero
Mensajes: 16
Registrado: 16 Sep 2016, 10:51
Contactar:

Re: Problema al instalar un programa en windows 10

Mensajepor tarruxe » 20 Oct 2016, 07:10

Parece que da problemas para mostrar la imagen con la captura del error que da al instalar la versión de 32 bits de "Microsoft Access Database Engine 2010 Redistributable"..... . Te pongo el texto del mensaje literal:

No se puede instalar la versión de 32 bits del motor de la base de datos de Microsoft Access 2010 porque actualmente tiene instalados productos de Office de 64 bits. Si desea instalar la versión de 32 bits del motor de la base de datos de Microsoft Access 2010, primero deberá desinstalar los productos de 64 bits de Office. Después de desinstalar los productos siguientes, ejecute de nuevo el programa de instalación para instalar la versión de 32 bits del motor de la base de datos Microsoft Access 2010: Microsoft Access Database Engine 2010 (Spanish)

Avatar de Usuario
pako
Usuario Bill Gates
Usuario Bill Gates
Mensajes: 3602
Registrado: 22 Ene 2008, 13:30
Ubicación: España
Agradecido : 50 veces
Agradecimiento recibido: 277 veces
Contactar:

Re: Problema al instalar un programa en windows 10

Mensajepor pako » 20 Oct 2016, 15:49

Hola,

Te comento como lo veo yo.

El programa que quieres usar es para XP, con lo cual será para 32bits, así que se supone que usara el "Microsoft Access Database Engine 2010 Redistributable" para 32 bits, el cual no tienes instalado, tienes instalado el de 64 bits.

En el texto que pusiste te dice eso, que tienes instalado el Office para 64bits y no te deja meter el "Microsoft Access..." para 32 bits. Te pone que desinstales primero todos los productos de Office y luego intentes instalar el 32 a ver si así te deja.

Usas el Office? puedes quitarle? tienes su cd y su contraseña?

Tu veras si puedes hacer la anterior prueba o no, si con lo anterior funciona, entonces tendrías que volver a instalar el Office después y no sé si te dejara meter el Office de 64bits al detectar un componente de 32 bits.

*******************************************

Referente a los errores que pones, entiendo que no son problemas de Windows, son errores de la propia aplicación con lo cual todos esos errores no ayudan, eso tendría que verlo el creador de la aplicación.

Lo único que veo interesante es la primera línea:

El proveedor 'Microsoft.Jet.OLEDB.4.0' no está registrado en el equipo local.

Y se debe referir a lo que te puse más arriba de instalar la versión de 32bits.

Te tocara hacer pruebas.

Si ninguna cosa te funciona, siempre puedes crearte una máquina virtual de XP con VirtualBox, así podrás cargar XP en una ventana dentro de tu Windows 10.

Saludos
Si has encontrado aquí la ayuda que esperabas (o incluso si no ha sido así ;) ), ayúdanos a mantener el foro con un pequeño donativo.
¡Muchas gracias!

rsuarez
Usuario linuxero
Usuario linuxero
Mensajes: 6
Registrado: 30 Ago 2016, 03:44
Contactar:

Re: Problema al instalar un programa en windows 10

Mensajepor rsuarez » 25 Oct 2016, 15:16

Muchas gracias por tus aportes.. lo tomare en cuenta y te diré si me ha funcionado. saludos.












Ricardo Suarez Caballero
Director Formativo en IIEMD.com -
https://iiemd.com/cursodecommunitymanager/



Volver a “Windows 10”

¿Quién está conectado?

Usuarios navegando por este Foro: No hay usuarios registrados visitando el Foro y 1 invitado