Problema con windows installer

Foro referente al sistema operativo Windows y que no se puede clasificar en los foros anteriores
cris_sebastian
Usuario linuxero
Usuario linuxero
Mensajes: 33
Registrado: 07 Mar 2009, 20:04
Contactar:

Re: Problema con windows installer

Mensajepor cris_sebastian » 12 Mar 2009, 14:17

a ver, hago todo eso, reinicio, uso el dial a fix, y al dar a FIX WINDOWS INSTALLER me sale esto:

http://img440.imageshack.us/img440/3452/72268880.jpg
http://img440.imageshack.us/img440/2654/wi2.jpg

Avatar de Usuario
Souto
Usuario Bill Gates
Usuario Bill Gates
Mensajes: 10665
Registrado: 25 Feb 2008, 10:21
Ubicación: Galicia
Agradecido : 6 veces
Agradecimiento recibido: 647 veces
Contactar:

Re: Problema con windows installer

Mensajepor Souto » 12 Mar 2009, 14:48

En una situación igual a la tuya
http://www.microsoft.com/communities/ne ... us&m=1&p=1

la solución fue realizar un chkdsk

http://support.microsoft.com/kb/315265/es

Saludos
Qui dove il mare luccica e tira forte il vento

cris_sebastian
Usuario linuxero
Usuario linuxero
Mensajes: 33
Registrado: 07 Mar 2009, 20:04
Contactar:

Re: Problema con windows installer

Mensajepor cris_sebastian » 12 Mar 2009, 16:41

a ver, pruebo a hacer eso, y desde simbolo de sistema no me ha dejado, me decia que no exisitia... Total, lo hago desde mi sistema, tengo que reinicar y al iniciarse hace la comprobacion, pero no me sale nada de esto que dice:


La tabla siguiente muestra los códigos de salida de los que informa Chkdsk tras haber finalizado la comprobación:
Código de salida Descripción
0 No se encontraron errores.
1 Se encontraron errores y se corrigieron.
2 Se realizaron operaciones del Liberador de espacio en disco, como el mantenimiento del caché, o la limpieza no se realizó porque no se especificó /f.
3 No se pudo comprobar el disco, no se pudieron corregir los errores, o éstos no se corrigieron porque no se especificó /f.


a lo mejor es que hago algo mal, pero creo que sigo esos pasos como pone en la pagina :S

Avatar de Usuario
Souto
Usuario Bill Gates
Usuario Bill Gates
Mensajes: 10665
Registrado: 25 Feb 2008, 10:21
Ubicación: Galicia
Agradecido : 6 veces
Agradecimiento recibido: 647 veces
Contactar:

Re: Problema con windows installer

Mensajepor Souto » 12 Mar 2009, 18:06

Probablemente Microsoft no lo explica bien y yo por falta de tiempo no he revisado el texo, disculpa.
Lo único que has realizado es una comprobación sin reparación.

Puedes hacerlo en cualquiera de estas dos formas:
A) Doble clic en MiPC, ratón derecho sobre el disco>>Propiedades>>Herramientas>>Comprobar ahora>> marcas Reparar automaticamente.../Iniciar.
Un mensaje te dirá que la unidad está en uso y ahora no se puede hacer, quedando programado tras el próximo reinicio.
En cuanto reinicies ó vuelvas a encender el equipo se lanzará la reparación (durará tiempo)

B) Inicio/Ejecutar: chkdsk C: /f

Saludos
Qui dove il mare luccica e tira forte il vento

cris_sebastian
Usuario linuxero
Usuario linuxero
Mensajes: 33
Registrado: 07 Mar 2009, 20:04
Contactar:

Re: Problema con windows installer

Mensajepor cris_sebastian » 12 Mar 2009, 18:44

vale, ya he hecho eso, ha tardado un ratillo mientras hacia la comprobacion... pero ahora que hago?

perdona que me cueste tanto xD, es que estas cosas me superan... =)
ymuchisimas gracias por ayudarme!!

Avatar de Usuario
Souto
Usuario Bill Gates
Usuario Bill Gates
Mensajes: 10665
Registrado: 25 Feb 2008, 10:21
Ubicación: Galicia
Agradecido : 6 veces
Agradecimiento recibido: 647 veces
Contactar:

Re: Problema con windows installer

Mensajepor Souto » 12 Mar 2009, 19:03

pero ahora que hago?

Pues simplemente vuelves a ejecutar el Dial a fix y compruebas si sigue dandoo eseos errores. Si ya no los da, tu tema debiera estar solucionado.
En caso contrario miraré alternativas.

Saludos
Qui dove il mare luccica e tira forte il vento

cris_sebastian
Usuario linuxero
Usuario linuxero
Mensajes: 33
Registrado: 07 Mar 2009, 20:04
Contactar:

Re: Problema con windows installer

Mensajepor cris_sebastian » 12 Mar 2009, 19:09

vaya, pues me sigue dando los mismos errores de antes... Doy a FIX W.I. y me sale lo mismo... =S
me extraña muchisimo que me pasen estas cosas porque mi pc, normalmente siempre ha ido bien y no me ha dado problemas...
pero ahora no me deja instalar nada el WI... =S

Avatar de Usuario
Souto
Usuario Bill Gates
Usuario Bill Gates
Mensajes: 10665
Registrado: 25 Feb 2008, 10:21
Ubicación: Galicia
Agradecido : 6 veces
Agradecimiento recibido: 647 veces
Contactar:

Re: Problema con windows installer

Mensajepor Souto » 12 Mar 2009, 23:34

Vamos a darle una últiima vuelta a ver si de esta va. Tómatelo con calma que el panfleto es largo. Si necesitas alguna aclaración, mañana lo veríamos.

PASO PRIMERO:
Comprobando el servicio
Comprobar en MSCONFIG que el servicio está en ejecución
Inicio/Ejecutar: msconfig
Verificar que en la pestaña Servicios está marcado Windows Installer.
En caso contrario corregir esto, dar en Aceptar y reiniciar el equipo

PASO SEGUNDO
Registrando el instalador
Si no tienes experiencia en manejar el Registro sáltate este paso y vete directamente al tercero
En Inicio/Buscar tecleamos: Msiexec.exe y obtendremos su ubicación.
Típicamente será C:\Windows\System32
A continuación Inicio/Ejecutar: regedit y navegamos hasta

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSIServer
En la ventana de la derecha hacemos doble clic sobre ImagePath. Y comprobamos que en la ventana de modificación del valor aparece la misma ruta que obtuvimos antes. En este caso : C:\Windows\System32\msiexec.exe /V De no ser así lo modificamos.

A continuación cerramos el editor del Registro, reiniciamos el equipo y antes de que arranque pulsamos reiteradamente F8 para que se nos muestren los modos de inicio avanzados.
Nos posicionamos con el cursor sobre Modo seguro y pulsamos Intro.
Una vez iniciada sesión, en Inicio/Ejecutar tecleamos : msiexec /regserver y damos en Aceptar.

A continuación reiniciamos el equipo en modo normal y comprobamos si el problema se ha resuelto
De no ser así..

PASO TERCERO :
Reinstalando Windows Installer
Inicio/Ejecutar : cmd
En la nueva ventana tecleamos uno a uno los siguiente comandos (intro después de cada uno) :
cd %windir%\System32
ren msi.dll msi.old
ren msiexec.exe msiexec.old
ren msihnd.dll msihnd.old
exit


Reiniciamos el equipo

Nos vamos a :
http://www.microsoft.com/downloads/deta ... laylang=es
para descargar e instalar la última versión del Instalador.

Para finalizar, reiniciamos el equipo y comprobamos si al fin, por fin......

Saludos y suerte!
Qui dove il mare luccica e tira forte il vento

cris_sebastian
Usuario linuxero
Usuario linuxero
Mensajes: 33
Registrado: 07 Mar 2009, 20:04
Contactar:

Re: Problema con windows installer

Mensajepor cris_sebastian » 13 Mar 2009, 00:41

paso primero y segundo, nada

en el tercero, despues de hacer todo, al descargar e instalar me sale esto:

http://img23.imageshack.us/img23/6419/pantallal.jpg


:S

gracias!

Avatar de Usuario
Souto
Usuario Bill Gates
Usuario Bill Gates
Mensajes: 10665
Registrado: 25 Feb 2008, 10:21
Ubicación: Galicia
Agradecido : 6 veces
Agradecimiento recibido: 647 veces
Contactar:

Re: Problema con windows installer

Mensajepor Souto » 13 Mar 2009, 10:56

Bueno, parece que hemos dado con el origen del problema. Se trata de una falta de permisos sobre cierta clave del Registro. A ver si hay suerte y no aparece después otro entuerto.

PASO PRIMERO:
Doble clic en MiPC>>Heramientas>>Opcionesde carpeta>>Tipos de archivo, localiza MSI y pulsas sobre él para resltarlo.
En la parte inferiór de es ventana das en Opciones avanzadas y en la nueva ventana pulsas sobre Repair y das en Aceptar.
Cierras todo eso. No necesitas probar nada porque todavía no está reparado.
Vamos ahora a la segunda parte

PASO SEGUNDO:
Reinicia el equipo, arranca en Modo seguro, entra con la cuenta Administrador y desde ella, navegando por el disco, localiza en tu cuenta el paquete de Windows installer y procede a instalarlo.
Reinicia el equipo en modo normal y comprueba si ahora ya puedes instalar cualquier programa

Si tampoco lo consigues...

PASO TERCERO:
Arrancando en modo normal
Inicio/Ejecutar: regedit
navega hasta la carpeta CLSID que está en la ventana de la izquierda siguiendo esta ruta: HKEY_CLASSES_ROOT\CLSID
pulsa con ratón derecho sobre ella>>Permisos. En la nueva ventana y de la lista de usuarios que aparece, pulsa sobre tu usuario y en la parte inferior marcas para la columna "Permitir" las casillas "Control total" y "leer".
A continuación pulsa sobre "Opciones avanzadas">>pestaña Permisos y marcas la casilla "heredar del objeto principal las entradas de permisos....."
Das en Aceptar y cierras todo.
Reinicias el equipo en modo normal y prueba ahora a ver si completas la instalación de Windows installer.


Saludos
Qui dove il mare luccica e tira forte il vento


Volver a “Windows en general”

¿Quién está conectado?

Usuarios navegando por este Foro: No hay usuarios registrados visitando el Foro y 1 invitado