Archivos "Setup"

Todo lo referente a la informatica, hardware, software... no necesariamente relacionado con Windows
Avatar de Usuario
knario
Usuario topetorpe
Usuario topetorpe
Mensajes: 175
Registrado: 28 Mar 2013, 11:32
Agradecido : 28 veces
Agradecimiento recibido: 16 veces
Contactar:

Archivos "Setup"

Mensajepor knario » 31 Ene 2015, 22:16

Hola.

Quisiera saber si los archivos de aplicación "Setup", o ".exe",
contienen archivos ".inf ".

El caso es que quiero agregar una serie de drivers en una ISO original de Win7,
al utilizar NLITE, y RT Seven Lite me pide archivos .inf,
y los drivers para agregar son "Setup".

No sé si habrá otro medio como "Hiren´s Boot" para agregar drivers
a un sistema o una ISO que no arranca.

Saludos.

Avatar de Usuario
Souto
Usuario Bill Gates
Usuario Bill Gates
Mensajes: 10665
Registrado: 25 Feb 2008, 10:21
Ubicación: Galicia
Agradecido : 6 veces
Agradecimiento recibido: 647 veces
Contactar:

Re: Archivos "Setup"

Mensajepor Souto » 01 Feb 2015, 11:06

Imagino que lo de los controladores va a cuento de ese portátil que, tal como me comentaste por MP, te está complicando la vida a la hora de instalarle W/.
Así que voy a aprovechar que me resulta más cómodo comunicarme por aquí que por MP para responderte a ambas cuestiones.

Para cuando un fabricante nos ofrece controladores en formato .exe y nosotros loq ue queremos son los .inf.
Se puede hacer cualquiera de estas dos cosas.
a) Realizar una extracción temporal en otro equipo, tal como explico aquí para el Intel Matrix
windows-xp-x64/instalar-xp-en-equipo-con-disco-sata-t5043.html
b) Más rápido y más simple. Instalar el descompresor 7 zip. Una vez instalado hacemos ratón derecho sobre el exe y vamos al diálogo 7zip>>Extract to.
En esta primera extracción podríamos ya obtener los .inf. En otro caso obtendriíamos uno o varios .msi. Simplemente otra vez ratón derecho sobre el .msi >>7zip>>Extract to...
y asunto concluido.

En cuanto al tema principal, no resulta práctico andar haciendo pruebas para averiguar porqué la instalación de W7 no progresa en ese equipo. Tiene mucho más sentido acceder (con un live Linux, por ejemplo) al log de instalación y mirar qué error informa ahí. Luego ya sabríamos a qué atenernos.
Para lolalicar el log:
http://support.microsoft.com/kb/927521

Nos cuentas :)
Qui dove il mare luccica e tira forte il vento

Avatar de Usuario
knario
Usuario topetorpe
Usuario topetorpe
Mensajes: 175
Registrado: 28 Mar 2013, 11:32
Agradecido : 28 veces
Agradecimiento recibido: 16 veces
Contactar:

Re: Archivos "Setup"

Mensajepor knario » 01 Feb 2015, 12:30

Así es, se trata de ese portátil.

Sobre los archivos me ha quedado... más o menos... claro.

Pero sobre; localizar el log de instalación y mirar qué error informa ahí, no lo entiendo,
porque no sé donde buscar, ya que la instalación NO INICIA.

Se queda eternamente cargando la barra verde de Microsoft Corporation.

VIDEO → https://www.youtube.com/watch?x-yt-cl=85114404&v=hE_FBFyrPuA&x-yt-ts=1422579428

Avatar de Usuario
knario
Usuario topetorpe
Usuario topetorpe
Mensajes: 175
Registrado: 28 Mar 2013, 11:32
Agradecido : 28 veces
Agradecimiento recibido: 16 veces
Contactar:

Re: Archivos "Setup"

Mensajepor knario » 01 Feb 2015, 12:54

http://support.microsoft.com/kb/927521

A que fase te refieres:

-Fase de nivel inferior: C:\$WINDOWS.~BT\Sources\Panther\PreGatherPnPList.log
-Fase del Entorno de preinstalación de Windows: C:\$WINDOWS.~BT\Sources\Panther\setuperr.log

Avatar de Usuario
Souto
Usuario Bill Gates
Usuario Bill Gates
Mensajes: 10665
Registrado: 25 Feb 2008, 10:21
Ubicación: Galicia
Agradecido : 6 veces
Agradecimiento recibido: 647 veces
Contactar:

Re: Archivos "Setup"

Mensajepor Souto » 01 Feb 2015, 13:08

El log más importante es el setuperr.log.
En cuanto a dónde hay que buscarlo depende de la fase de instalación en que estemos.
En cualquier caso había entendido, tal vez erróneamente, que estás haciendo un imagex /apply y si es así, no me encaja lo que veo; porque la pantalla debería mostrar la segunda fase (creación de usuario)

Al final de la tarde le doy una vuelta.
Qui dove il mare luccica e tira forte il vento

Avatar de Usuario
knario
Usuario topetorpe
Usuario topetorpe
Mensajes: 175
Registrado: 28 Mar 2013, 11:32
Agradecido : 28 veces
Agradecimiento recibido: 16 veces
Contactar:

Re: Archivos "Setup"

Mensajepor knario » 01 Feb 2015, 13:17

Habías entendido bien, se ha hecho un imagex /apply,
entonces busco la ruta: C:\$WINDOWS.~BT\Sources\Panther\setuperr.log

Avatar de Usuario
Souto
Usuario Bill Gates
Usuario Bill Gates
Mensajes: 10665
Registrado: 25 Feb 2008, 10:21
Ubicación: Galicia
Agradecido : 6 veces
Agradecimiento recibido: 647 veces
Contactar:

Re: Archivos "Setup"

Mensajepor Souto » 01 Feb 2015, 18:25

Vamos primero a decirle a quien esté siguiendo esto de qué hablamos:
"Compaq Mini", NO puedo instalar Windows, pero Si Linux.


¿La captura que pones (Windows cargando archivos) se refiere al principio ?. Es decir, estás arrancando desde un USB con Windows 7 o desde un USB con Windows PE?.
O Tal vez ya hiciste imagex /apply y en lugar de finalizar la instalación aparece Windows is loading..?
Si estamos en el primer caso, sea Windows7 o sea Windows PE ¿estás usando un 32 bits o un 64?

Saludos
Qui dove il mare luccica e tira forte il vento

Avatar de Usuario
knario
Usuario topetorpe
Usuario topetorpe
Mensajes: 175
Registrado: 28 Mar 2013, 11:32
Agradecido : 28 veces
Agradecimiento recibido: 16 veces
Contactar:

Re: Archivos "Setup"

Mensajepor knario » 01 Feb 2015, 18:58

Exactamente, el video corresponde al principio de la instalación.

-Tenía Windows 7 Starter de fábrica.
-NO tiene UEFI
-Tiene sólo un módulo de 1GB de RAM.
-HDD 250GB.

-Se han borrado todas las particiones con "Diskpart"
-Se ha intentado de instalar el S.O.Win7 desde un pendrive, y se queda cargando eternamente en la misma pantalla.
-Se ha probado el pendrive de instalación en otro ordenador, y arranca perfectamente.
-Se ha implementado el S.O. con imagex /apply, y se queda cargando eternamente en la misma pantalla.
-Se ha probado ese mismo disco duro en otro ordenador, y arranca perfectamente.
-Se han creado particiones independientes para archivos de instalación, y se queda cargando eternamente en la misma pantalla.
-Se ha probado el disco duro con las particiones creadas independientes en otro ordenador, y arranca perfectamente.
-Se ha probado con una nueva ISO de instalación, con el mismo resultado
-Se ha utilizado el Memtest86+ y no ha encontrado ningún error en la RAM.
-El estado de salud del disco duro es BUENO.

Sin embargo con "Linux" NO tiene ningún problema.

Avatar de Usuario
Souto
Usuario Bill Gates
Usuario Bill Gates
Mensajes: 10665
Registrado: 25 Feb 2008, 10:21
Ubicación: Galicia
Agradecido : 6 veces
Agradecimiento recibido: 647 veces
Contactar:

Re: Archivos "Setup"

Mensajepor Souto » 01 Feb 2015, 19:15

Se ha implementado el S.O. con imagex /apply, y se queda cargando eternamente en la misma pantalla.

Es decir esto se ha ejecutado, has visto algo similar a esto en la pantalla??

Imagen

Saludos
Qui dove il mare luccica e tira forte il vento

Avatar de Usuario
knario
Usuario topetorpe
Usuario topetorpe
Mensajes: 175
Registrado: 28 Mar 2013, 11:32
Agradecido : 28 veces
Agradecimiento recibido: 16 veces
Contactar:

Re: Archivos "Setup"

Mensajepor knario » 01 Feb 2015, 19:31

Se ha implementado la imagen con Windows AIK

Imagen

Y luego se han creado los archivos de arranque.

Imagen


Volver a “Informática”

¿Quién está conectado?

Usuarios navegando por este Foro: No hay usuarios registrados visitando el Foro y 1 invitado